infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Thistlethwaite (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-16152) Login to Apache Blogs site fails with Velocity template error
Date Tue, 03 Apr 2018 19:17:00 GMT

    [ https://issues.apache.org/jira/browse/INFRA-16152?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16424465#comment-16424465
] 

Chris Thistlethwaite commented on INFRA-16152:
----------------------------------------------

users.ldap.autoProvision.enabled seems to be enabled
I didn't find anything in roller.log for BasicUserAutoProvision
We're currently at 5.1.2, does 5.2 have better reporting?

I think just for troubleshooting I'd like to remove the special characters from LDAP and see
if Jiří can log in. While that's not a fix, it would at least rule out any special character
issues. [~jkovalsky] are you OK with trying that? If you want to jump on HipChat again, I
can change it realtime.

> Login to Apache Blogs site fails with Velocity template error
> -------------------------------------------------------------
>
>                 Key: INFRA-16152
>                 URL: https://issues.apache.org/jira/browse/INFRA-16152
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: Blogs
>            Reporter: Jiří Kovalský
>            Assignee: Chris Thistlethwaite
>            Priority: Major
>         Attachments: Cursor_and_testblog.jpg, exception.txt
>
>
> For some reason I cannot login to Apache Blogs site [1] due to Velocity template error
[2]. Tried with anonymous mode with same result. My username is "jkovalsky". Can you please
help me? Thanks!
> [1] https://blogs.apache.org/roller-ui/login.rol
> [2] Exception Velocity template error : standard
> Message 	Invocation of method 'getAuthorMenu' in class org.apache.roller.weblogger.ui.rendering.model.MenuModel
threw exception java.lang.NullPointerException at weblog.vm[line 674, column 34]
> Type 	2c8995ce-ea14-4c95-a539-35091a206f32
> Exception 	org.apache.velocity.exception.MethodInvocationException



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message