infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Johnson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-16152) Login to Apache Blogs site fails with Velocity template error
Date Sun, 01 Apr 2018 15:01:00 GMT

    [ https://issues.apache.org/jira/browse/INFRA-16152?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16421682#comment-16421682
] 

David Johnson commented on INFRA-16152:
---------------------------------------

[~jkovalsky] sorry about the delay on this.

Following up on my previous comment:

"The NPE occurs when Roller attempts to get permissions for the user jkovalsky but the user
object is null, which means that Roller was unable to look up the user. In the Roller admin
interface, I cannot find a user named jkovalsky"  I confirmed via the Roller Admin UI that
there is no user named jkovalsky in the Roller database.  Quesiton is, why is there no user
there; the LDAP integration should have created one.

Typically, what happens with LDAP is this: the LDAP system authenticates the user and hands
the username to Roller, if the Roller property "users.ldap.autoProvision.enabled" is true,
then Roller will provision a User object to represent the user in the Roller database.

RollerSession.java calls the AutoProvisioner to create a new user:
https://github.com/apache/roller/blob/c6459e5c707cf4f4903b2b408a6ac3fb8f6b5adc/app/src/main/java/org/apache/roller/weblogger/ui/core/RollerSession.java#L97


The AutoProvisioner creates and saves the User object in the Roller database:
https://github.com/apache/roller/blob/master/app/src/main/java/org/apache/roller/weblogger/ui/core/security/BasicUserAutoProvision.java

Here are some things we can try to debug this:

* check that the "users.ldap.autoProvision.enabled" variable is set as it defaults to "false"
... but if this property is false, how did blogs ever work with LDAP?
* check logs for any warning or error messages that mention "BasicUserAutoProvision"
* deploy a new version of Roller, patched to give better error reporting in the LDAP integration

[~cthistle] let me know if I can help with any of the above.

> Login to Apache Blogs site fails with Velocity template error
> -------------------------------------------------------------
>
>                 Key: INFRA-16152
>                 URL: https://issues.apache.org/jira/browse/INFRA-16152
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: Blogs
>            Reporter: Jiří Kovalský
>            Assignee: Chris Thistlethwaite
>            Priority: Major
>         Attachments: Cursor_and_testblog.jpg, exception.txt
>
>
> For some reason I cannot login to Apache Blogs site [1] due to Velocity template error
[2]. Tried with anonymous mode with same result. My username is "jkovalsky". Can you please
help me? Thanks!
> [1] https://blogs.apache.org/roller-ui/login.rol
> [2] Exception Velocity template error : standard
> Message 	Invocation of method 'getAuthorMenu' in class org.apache.roller.weblogger.ui.rendering.model.MenuModel
threw exception java.lang.NullPointerException at weblog.vm[line 674, column 34]
> Type 	2c8995ce-ea14-4c95-a539-35091a206f32
> Exception 	org.apache.velocity.exception.MethodInvocationException



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message