infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Johnson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-16152) Login to Apache Blogs site fails with Velocity template error
Date Sat, 28 Apr 2018 18:38:00 GMT

    [ https://issues.apache.org/jira/browse/INFRA-16152?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16457746#comment-16457746
] 

David Johnson commented on INFRA-16152:
---------------------------------------

Hi [~cthistle]. I was able to get to the Create User page by entering the URL and I attempted
to create a new user for Jiří but I got an error message. Would you please take a look at
the logs and see if you can find an error related to this URL

    https://blogs.apache.org/roller-ui/admin/createUser.rol

Or the word "createUser". Or you could go to the above URL and reproduce the error. The stack
trace might give us some clues about why the user's login is failing. 

Sorry about the long delay! I don't have much time to work on this except for weekends.

> Login to Apache Blogs site fails with Velocity template error
> -------------------------------------------------------------
>
>                 Key: INFRA-16152
>                 URL: https://issues.apache.org/jira/browse/INFRA-16152
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: Blogs
>            Reporter: Jiří Kovalský
>            Assignee: Chris Thistlethwaite
>            Priority: Major
>         Attachments: Cursor_and_testblog.jpg, exception.txt
>
>
> For some reason I cannot login to Apache Blogs site [1] due to Velocity template error
[2]. Tried with anonymous mode with same result. My username is "jkovalsky". Can you please
help me? Thanks!
> [1] https://blogs.apache.org/roller-ui/login.rol
> [2] Exception Velocity template error : standard
> Message 	Invocation of method 'getAuthorMenu' in class org.apache.roller.weblogger.ui.rendering.model.MenuModel
threw exception java.lang.NullPointerException at weblog.vm[line 674, column 34]
> Type 	2c8995ce-ea14-4c95-a539-35091a206f32
> Exception 	org.apache.velocity.exception.MethodInvocationException



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message