infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ufuk Celebi (JIRA)" <>
Subject [jira] [Commented] (INFRA-15959) Use Ruby >= 2.1 for Flink buildbot
Date Tue, 06 Feb 2018 13:40:00 GMT


Ufuk Celebi commented on INFRA-15959:

Another question: what's your recommended way of resolving

RVM is not a function, selecting rubies with 'rvm use ...' will not work.

You need to change your terminal emulator preferences to allow login shell.
Sometimes it is required to use `/bin/bash --login` as the command.
Please visit for an example.
when doing `rvm use ruby-2.3.1`?

> Use Ruby >= 2.1 for Flink buildbot
> ----------------------------------
>                 Key: INFRA-15959
>                 URL:
>             Project: Infrastructure
>          Issue Type: Wish
>          Components: Buildbot
>            Reporter: Ufuk Celebi
>            Assignee: Daniel Takamori
>            Priority: Major
> Hey Infra-Team! I have a question on behalf of the Flink PMC. Is it possible to get a
newer Ruby version in the buildbot environment? We use buildbot for generating Flink docs
via Jekyll and the version we get is {{ruby 2.0.0p384 (2014-01-12) [x86_64-linux-gnu]}}. We
want to upgrade Jekyll due to a security issue reported by security@ and that requires the
newer Ruby version.
> Related Flink issue is here:

This message was sent by Atlassian JIRA

View raw message