infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ufuk Celebi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-15959) Use Ruby >= 2.1 for Flink buildbot
Date Tue, 06 Feb 2018 13:30:00 GMT

    [ https://issues.apache.org/jira/browse/INFRA-15959?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16353872#comment-16353872
] 

Ufuk Celebi commented on INFRA-15959:
-------------------------------------

I'm probably messing something up.

This build using rvm on slave2 had no problems: https://ci.apache.org/builders/flink-docs-master/builds/983/steps/Flink%20docs/logs/stdio

But this build on slave1 did have problems: https://ci.apache.org/builders/flink-docs-master/builds/984/steps/Flink%20docs/logs/stdio:
```
/bin/sh: 3: rvm: not found
/bin/sh: 4: rvm: not found
```

Looking at the linked logs, for the successful one I see env variables like `rvm_bin_path`
that are not available on slave1. Any ideas why this might be the case?


> Use Ruby >= 2.1 for Flink buildbot
> ----------------------------------
>
>                 Key: INFRA-15959
>                 URL: https://issues.apache.org/jira/browse/INFRA-15959
>             Project: Infrastructure
>          Issue Type: Wish
>          Components: Buildbot
>            Reporter: Ufuk Celebi
>            Assignee: Daniel Takamori
>            Priority: Major
>
> Hey Infra-Team! I have a question on behalf of the Flink PMC. Is it possible to get a
newer Ruby version in the buildbot environment? We use buildbot for generating Flink docs
via Jekyll and the version we get is {{ruby 2.0.0p384 (2014-01-12) [x86_64-linux-gnu]}}. We
want to upgrade Jekyll due to a security issue reported by security@ and that requires the
newer Ruby version.
> Related Flink issue is here: https://issues.apache.org/jira/browse/FLINK-8308



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message