infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ufuk Celebi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-15959) Use Ruby >= 2.1 for Flink buildbot
Date Mon, 05 Feb 2018 13:28:00 GMT

    [ https://issues.apache.org/jira/browse/INFRA-15959?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16352369#comment-16352369
] 

Ufuk Celebi commented on INFRA-15959:
-------------------------------------

[~pono] Thanks for looking into this. I just realized that this won't work for our build setup,
because the documentation build scripts that are part of the main flink repo reference vanilla
{{ruby}} commands.

I've seen that on some machines {{rvm}} is available ({{bb_slave2_ubuntu}}) but not on others
({{bb_slave_1_ubuntu}}). Is is possible to have {{rvm}} on all machines?


> Use Ruby >= 2.1 for Flink buildbot
> ----------------------------------
>
>                 Key: INFRA-15959
>                 URL: https://issues.apache.org/jira/browse/INFRA-15959
>             Project: Infrastructure
>          Issue Type: Wish
>          Components: Buildbot
>            Reporter: Ufuk Celebi
>            Assignee: Daniel Takamori
>            Priority: Major
>
> Hey Infra-Team! I have a question on behalf of the Flink PMC. Is it possible to get a
newer Ruby version in the buildbot environment? We use buildbot for generating Flink docs
via Jekyll and the version we get is {{ruby 2.0.0p384 (2014-01-12) [x86_64-linux-gnu]}}. We
want to upgrade Jekyll due to a security issue reported by security@ and that requires the
newer Ruby version.
> Related Flink issue is here: https://issues.apache.org/jira/browse/FLINK-8308



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message