infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gavin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-15448) Provide Gradle 4.3 for build with Java 9.0.1
Date Wed, 10 Jan 2018 07:28:01 GMT

    [ https://issues.apache.org/jira/browse/INFRA-15448?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16319817#comment-16319817
] 

Gavin commented on INFRA-15448:
-------------------------------

interesting

I see the error you are talking about:

05:53:02 ERROR: No tool found matching GRADLE_3_4_RC_2_HOME
05:53:02 Setting GRADLE_4_3_HOME=/home/jenkins/tools/gradle/4.3

looking further

> Provide Gradle 4.3 for build with Java 9.0.1
> --------------------------------------------
>
>                 Key: INFRA-15448
>                 URL: https://issues.apache.org/jira/browse/INFRA-15448
>             Project: Infrastructure
>          Issue Type: Task
>          Components: Buildbot, Jenkins
>            Reporter: Ted Yu
>            Assignee: Daniel Takamori
>         Attachments: Screen Shot 2017-11-29 at 12.14.34 pm.png, Screen Shot 2017-11-29
at 12.14.52 pm.png
>
>
> Kafka jdk9 Jenkins jobs have been failing against Java 9.0.1.
> e.g.
> https://builds.apache.org/job/kafka-trunk-jdk9/170 :
> {code}
> + /home/jenkins/jenkins-slave/tools/hudson.plugins.gradle.GradleInstallation/Gradle_3.4-rc-2/bin/gradle
> FAILURE: Build failed with an exception.
> * What went wrong:
> Could not determine java version from '9.0.1'.
> {code}
> See this discussion:
> https://discuss.gradle.org/t/could-not-determine-java-version-from-9-0-1/24457/18
> When configuring Kafka Jenkins, I don't see Gradle 4.x among the selection.
> Please install Gradle 4.3 on build machines.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message