infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gavin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-15175) openjdk7 not available on ubuntu, JDK wiki page broken
Date Fri, 29 Sep 2017 03:55:00 GMT

    [ https://issues.apache.org/jira/browse/INFRA-15175?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16185316#comment-16185316
] 

Gavin commented on INFRA-15175:
-------------------------------

The docs clearly state 'ubuntu' label. The 'Ubuntu' label was discontinued years ago.

"Limited availabilty depending on OS Version

Our 'ubuntu' label contains both 14.04 LTS and 16.04 LTS nodes. This is fine in general however
for the following default OpenJDK packages they are split between:-

    14.04 LTS nodes have OpenJDK 6 and 7 available.
    16.04 LTS nodes have OpenJDK 8 and 9 available."

So, your build ran on H24 which is a xenial machine, 16.04 and so it is correct that it is
not installed.

try using 'ubuntu && !xenial' 

> openjdk7 not available on ubuntu, JDK wiki page broken
> ------------------------------------------------------
>
>                 Key: INFRA-15175
>                 URL: https://issues.apache.org/jira/browse/INFRA-15175
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: Jenkins
>            Reporter: Patrick Hunt
>            Priority: Blocker
>
> I setup a Jenkins job to use openjdk7, I set the label to "ubuntu" however it's not finding
open jdk 7.
> example: https://builds.apache.org/view/S-Z/view/ZooKeeper/job/ZooKeeper-trunk-openjdk7/1633/console
> [ZooKeeper-trunk-openjdk7] $ /home/jenkins/tools/ant/latest/bin/ant -Dtest.output=yes
-Dtest.junit.threads=8 -Dtest.junit.output.format=xml -Djavac.target=1.7 clean test-core-java
> Error: JAVA_HOME is not defined correctly.
>   We cannot execute /usr/lib/jvm/java-7-openjdk-amd64//bin/java
> I tried setting the label to "Ubuntu" however that says that there are only two nodes
and they are both down. It's not clear if the JDK docs are referring to ubuntu machines ("ubuntu"
label) or specifically "Ubuntu" label. Either way it's not working.
> Additionally I tried using the docs here:
> https://cwiki.apache.org/confluence/display/INFRA/JDK+Installation+Matrix
> however things like this link are 404ing.
> Status of JDK Installations on Ubuntu nodes: https://builds.apache.org/view/I/view/Infrastructure/job/infra-test-jdk-ubuntu/
> results in:
> HTTP Status [404] – [Not Found]
> Type Status Report
> Description The origin server did not find a current representation for the target resource
or is not willing to disclose that one exists.
> Apache Tomcat/9.0.0.M20



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message