infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Han (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (INFRA-13526) ZooKeeper PreCommit/trunk/branch-3.5 build is failing due to Unsupported major.minor version 52.0
Date Mon, 13 Mar 2017 18:00:45 GMT

    [ https://issues.apache.org/jira/browse/INFRA-13526?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15913972#comment-15913972
] 

Michael Han commented on INFRA-13526:
-------------------------------------

The jobs are fixed by updating 1.9.9 version of ant.

One job has another particular issue regarding apache forrest installation:

BUILD FAILED
/home/jenkins/jenkins-slave/workspace/ZooKeeper_branch34/build.xml:449: Execute failed: java.io.IOException:
Cannot run program "${FORREST_HOME}/bin/forrest" (in directory "/home/jenkins/jenkins-slave/workspace/ZooKeeper_branch34/src/docs"):
error=2, No such file or directory

Is there any way to figure out where forrest is installed on build bot? I had a couple of
wild guesses which failed so far.
The failing job is https://builds.apache.org/view/All/job/ZooKeeper-trunk/. Should I create
a new infra issue for this?

cc [~rakeshr]

> ZooKeeper PreCommit/trunk/branch-3.5 build is failing due to Unsupported major.minor
version 52.0
> -------------------------------------------------------------------------------------------------
>
>                 Key: INFRA-13526
>                 URL: https://issues.apache.org/jira/browse/INFRA-13526
>             Project: Infrastructure
>          Issue Type: Bug
>          Components: Jenkins
>            Reporter: Rakesh R
>            Assignee: Gavin
>            Priority: Critical
>
> Apache ZooKeeper builds for PreCommit/trunk/branch-3.5 has been failing due to {{Unsupported
major.minor version 52.0}}.
> References:
> https://builds.apache.org/job/PreCommit-ZOOKEEPER-github-pr-build/336/console
> https://builds.apache.org/job/ZooKeeper-trunk-openjdk7/
> https://builds.apache.org/job/ZooKeeper_branch35_openjdk7/419/console
> Error Log:
> {code}
> [ZooKeeper_branch35_openjdk7] $ /home/jenkins/tools/ant/latest/bin/ant -Dtest.output=yes
-Dtest.junit.threads=8 -Dtest.junit.output.format=xml -Djavac.target=1.7 clean test-core-java
> Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/tools/ant/launch/Launcher
: Unsupported major.minor version 52.0
> 	at java.lang.ClassLoader.defineClass1(Native Method)
> 	at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
> 	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
> 	at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
> 	at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
> 	at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
> 	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
> 	at java.security.AccessController.doPrivileged(Native Method)
> 	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
> 	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
> 	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
> 	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
> 	at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)
> Build step 'Invoke Ant' marked build as failure
> {code}
> Appreciate your help in resolving this problem. Thanks!



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message