infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ariel Constenla-Haile (JIRA)" <j...@apache.org>
Subject [jira] [Created] (INFRA-12786) cygwin installation broken
Date Thu, 20 Oct 2016 13:42:58 GMT
Ariel Constenla-Haile created INFRA-12786:
---------------------------------------------

             Summary: cygwin installation broken
                 Key: INFRA-12786
                 URL: https://issues.apache.org/jira/browse/INFRA-12786
             Project: Infrastructure
          Issue Type: Task
          Components: Buildbot
            Reporter: Ariel Constenla-Haile


After the changes made for INFRA-12629 the Windows 7 buildbot is failing, see

https://ci.apache.org/builders/aoo-win7?numbuilds=50
https://ci.apache.org/builders/aoo-w741x?numbuilds=30

It looks like bash is not sourcing /etc/profile so the PATH environment variable is not exported
and the svn command is not found.

This may be fixed by downloading https://www.cygwin.com/setup-x86.exe again and running the
cygwin installer, maybe reinstall bash.

To test that cygwin is working, run the following inside cmd.exe:

C:\cygwin\bin\bash.exe -cliex "ls -l ~/"

Now that cygwin is broken, in stderr you only get the output you can see for example in red
on https://ci.apache.org/builders/aoo-win7/builds/459/steps/delete%20old%20build/logs/stdio
If this bug is fixed, stderr should dispaly the output of sourcing /etc/profile and the like.




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message