infra-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gavin (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (INFRA-7049) buildbot openjpa-trunk-docs build failures needs openjpa.conf update
Date Sun, 08 Dec 2013 06:09:46 GMT

     [ https://issues.apache.org/jira/browse/INFRA-7049?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gavin updated INFRA-7049:
-------------------------

    Status: Waiting for user  (was: Waiting for Infra)

Yeah so 1.7 was not on there, but it is now, in the location you guessed.

So go ahead and play, let me know if you need anything, or close this issue when happy, 

thanks.

> buildbot openjpa-trunk-docs build failures needs openjpa.conf update
> --------------------------------------------------------------------
>
>                 Key: INFRA-7049
>                 URL: https://issues.apache.org/jira/browse/INFRA-7049
>             Project: Infrastructure
>          Issue Type: Improvement
>          Components: Buildbot
>            Reporter: Albert Lee
>            Assignee: Gavin
>
> Recent http://ci.apache.org/builders/openjpa-trunk-docs/builds/251 failure is due to
openjpa.trunk moved up to use jdk 1.7 for build. 
> After looking at buildbot.openjpa.conf, the following code snippet needs enhancement
from:
>     if b_ojpa_b.startswith('1.'):
>         ojpa_builder['env'] = {'JAVA_HOME': '/home/buildslave2/slave2/tools/java/latest1.5/'}
>     c['builders'].append(ojpa_builder)
> to
>     if b_ojpa_b.startswith('1.'):
>         ojpa_builder['env'] = {'JAVA_HOME': '/home/buildslave2/slave2/tools/java/latest1.5/'}
>     if b_ojpa_b.startswith('trunk'):
>         ojpa_builder['env'] = {'JAVA_HOME': '/home/buildslave2/slave2/tools/java/latest1.7/'}
>     c['builders'].append(ojpa_builder)
> * I need to verify if "'/home/buildslave2/slave2/tools/java/latest1.7/" is the correct
JAVA_HOME to use for 1.7 JDK.
> * The 2 "if" statements can be optimized. What is the correct syntax to perform the desired
behavior? A sample code snippet would be very helpful since I am not that familiar with the
scripting language.
> * BTW, the check for "1." to set 1.5 JDK is still needed in additional to the 1.7 JDK
check.
> Thanks.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message