incubator-zeta-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jerome Renard <jerome.ren...@gmail.com>
Subject Re: [zeta-dev] Naming convention : *List variables
Date Mon, 07 Mar 2011 18:19:22 GMT
Derick, Patrick,

On Mon, Mar 7, 2011 at 7:09 PM, Patrick ALLAERT
<patrick.allaert@gmail.com> wrote:
> 2011/3/7 Jerome Renard <jerome.renard@gmail.com>:
[...]
>
> There is nothing wrong being explicit about the content of the
> variable, but I would refrain from using types like "Array", "List",
> "Integer",...

Maybe I have not been clear enough.

The point is not to name a variable acording to its type for ints,
floats etc, etc.

The point is to provide a visual/semantic help for arrays (or
hastables) *only* by suffixing them.
Using a variable in its plural form might not be ideal for some
people, this is what I am
trying to adress with this idea, which maybe is a stupid one.

The rest (int and others) remains unchanged.

:)

-- 
Jérôme Renard
http://39web.fr | http://jrenard.info | http://twitter.com/jeromerenard

Mime
View raw message