incubator-yoko-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick McGuire <rick...@gmail.com>
Subject Re: Yoko trunk build error.
Date Wed, 31 Oct 2007 15:48:15 GMT
And it turns out the situation is even more annoying.  It appears the 
change I had to make timed out and the file I changed was refreshed when 
I built this morning :-(

Rick

Alan D. Cabrera wrote:
> Does anyone in maven-land know why we have to do this?
>
>
> Regards,
> Alan
>
>
> On Oct 31, 2007, at 2:11 AM, Rick McGuire wrote:
>
>> I finally managed to get this to build, but it wasn't a pretty 
>> process.  Here were the steps:
>>
>> 1)  I upgraded my maven version to 2.0.7.
>> 2)  Attempt to rebuild 2.0.7.  This will fail also, but with a 
>> different error.  In order to patch things up, you need to attempt 
>> this with 2.0.7 and allow it to fail, otherwise you won't be able to 
>> do step 3).
>> 3)  In the maven repository, go to directory 
>> org/codehaus/plexus/plexus-archiver and edit the file 
>> maven-metadata-central.xml and add the version       
>> <version>1.0-alpha-10-SNAPSHOT</version> to the list.
>> 4)  Rebuild again...it should work this time.
>>
>> Rick
>>
>> Lars K├╝hne wrote:
>>> Rick McGuire wrote:
>>>> [INFO] 
>>>> ------------------------------------------------------------------------

>>>>
>>>> [ERROR] FATAL ERROR
>>>> [INFO] 
>>>> ------------------------------------------------------------------------

>>>>
>>>> [INFO] org/codehaus/plexus/util/FileUtils$FilterWrapper
>>>> [INFO] 
>>>> ------------------------------------------------------------------------

>>>>
>>>> [INFO] Trace
>>>> java.lang.NoClassDefFoundError: 
>>>> org/codehaus/plexus/util/FileUtils$FilterWrapper
>>>>
>>>>        at 
>>>> org.apache.maven.plugin.resources.ResourcesMojo.copyFile(ResourcesMoj
>>>> o.java:235)
>>>
>>>
>>> Same here.
>>>
>>> Lars
>>>
>>
>>
>
>


Mime
View raw message