incubator-yoko-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Fwd: Re: Yoko trunk build error.
Date Wed, 31 Oct 2007 17:51:51 GMT

Just realized this reply went to dev@maven instead of to yoko.

Dan


----------  Forwarded Message  ----------

Subject: Re: Yoko trunk build error.
Date: Wednesday 31 October 2007
From: Daniel Kulp <dkulp@apache.org>
To: dev@maven.apache.org


Actually, it's probably the other way...   You have plugin snapshots 
turned on:
        <pluginRepository>
            <id>apache-snapshots</id>
            <name>Maven apache plugins snapshot repository</name>
            <url>http://people.apache.org/maven-snapshot-repository</url>
            <layout>default</layout>
            <snapshots>
                <enabled>true</enabled>
            </snapshots>
            <releases>
                <updatePolicy>never</updatePolicy>
            </releases>
        </pluginRepository>

Thus, you'r probaby getting SNAPSHOT versions of various plugins that may 
or may not be working.

I would suggest removing that.

Either that, or lock down the resources plugin to the latest release 
version.

Dan



On Wednesday 31 October 2007, John Casey wrote:
> Just a guess, but you may be using an old version of the resource
> plugin. It looks like it's using but not declaring a direct
> dependency on plexus-utils, and if/when maven ceases to export that
> dependency to the plugin as part of the parent classloader, it fails.
>
> Again, just a guess.
>
> -john
>
> On Oct 31, 2007, at 11:18 AM, Alan D. Cabrera wrote:
> > Does anyone in maven-land know why we have to do this?
> >
> >
> > Regards,
> > Alan
> >
> > On Oct 31, 2007, at 2:11 AM, Rick McGuire wrote:
> >> I finally managed to get this to build, but it wasn't a pretty
> >> process.  Here were the steps:
> >>
> >> 1)  I upgraded my maven version to 2.0.7.
> >> 2)  Attempt to rebuild 2.0.7.  This will fail also, but with a
> >> different error.  In order to patch things up, you need to attempt
> >> this with 2.0.7 and allow it to fail, otherwise you won't be able
> >> to do step 3).
> >> 3)  In the maven repository, go to directory org/codehaus/plexus/
> >> plexus-archiver and edit the file maven-metadata-central.xml and
> >> add the version       <version>1.0-alpha-10-SNAPSHOT</version> to
> >> the list.
> >> 4)  Rebuild again...it should work this time.
> >>
> >> Rick
> >>
> >> Lars K├╝hne wrote:
> >>> Rick McGuire wrote:
> >>>> [INFO]
> >>>> --------------------------------------------------------------
> >>>>-- -----
> >>>> [ERROR] FATAL ERROR
> >>>> [INFO]
> >>>> -----------------------------------------------------------------
> >>>>-- -----
> >>>> [INFO] org/codehaus/plexus/util/FileUtils$FilterWrapper
> >>>> [INFO]
> >>>> -----------------------------------------------------------------
> >>>>-- -----
> >>>> [INFO] Trace
> >>>> java.lang.NoClassDefFoundError: org/codehaus/plexus/util/
> >>>> FileUtils$FilterWrapper
> >>>>
> >>>>        at
> >>>> org.apache.maven.plugin.resources.ResourcesMojo.copyFile
> >>>> (ResourcesMoj
> >>>> o.java:235)
> >>>
> >>> Same here.
> >>>
> >>> Lars
> >
> > --------------------------------------------------------------------
> >- To unsubscribe, e-mail: dev-unsubscribe@maven.apache.org
> > For additional commands, e-mail: dev-help@maven.apache.org
>
> ---
> John Casey
> Committer and PMC Member, Apache Maven
> mail: jdcasey at commonjava dot org
> blog: http://www.ejlife.net/blogs/john
> rss: http://feeds.feedburner.com/ejlife/john



-- 
J. Daniel Kulp
Principal Engineer
IONA
P: 781-902-8727    C: 508-380-7194
daniel.kulp@iona.com
http://www.dankulp.com/blog

-------------------------------------------------------

-- 
J. Daniel Kulp
Principal Engineer
IONA
P: 781-902-8727    C: 508-380-7194
daniel.kulp@iona.com
http://www.dankulp.com/blog

Mime
View raw message