incubator-yoko-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lars K├╝hne <lakue...@t-online.de>
Subject Re: Test failure on current build
Date Tue, 20 Feb 2007 21:11:51 GMT
Vescovi, Matteo wrote:
> Hi Lars,
> the tools module builds and tests fine for me.
>
> Do you still get this failure?
>

Yes, I see this test failure in the Maven build and inside Eclipse. When 
I debug IDLToWSDLGenerationTest.testStringGeneration(), I see that the 
generated output is

<wsdl:definitions targetNamespace=...>

  <corba:typeMapping targetNamespace="http://schemas.apache.org/yoko/idl/String/typemap">

    <corba:anonstring ...

    ...

    <corba:struct ...

      ...

    </corba:struct>

    </corba:typeMapping>

  <wsdl:types>


The indentation of the closing tag for typeMapping is incorrect (4, 
should be 2), and the test catches that.

Not sure why this test fails for me and not for you. I tried to debug 
this, but for now I got stuck in 
WSDLCorbaWriterImpl.printExtensibilityElements() where the super class 
is called, because that is inside wsdl4j.jar which doesn't seem to have 
debug information included.

I'm working on Linux, tools revision 509720 (i.e. latest and greatest). 
My platform encoding is UTF-8 if that matters (I saw that the test uses 
the platform encoding for char<->byte conversion).

Cheers,
Lars


Mime
View raw message