incubator-yoko-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexey Petrenko" <alexey.a.petre...@gmail.com>
Subject Re: [build] Yoko build problems
Date Fri, 14 Jul 2006 18:24:35 GMT
2006/7/14, Alexey Petrenko <alexey.a.petrenko@gmail.com>:
> 2006/7/14, Daniel Kulp <daniel.kulp@iona.com>:
> > > 2. If central specified as one of the repositories why Maven do not
> > > log an attempt to download concurrent from it?
> >
> > I think it did, but it doesn't always log connections to "central".   You're
> > log does say:
> >
> > >from the specified remote repositories:
> > >  central (http://repo1.maven.org/maven2),
> > >   java.net (https://maven-repository.dev.java.net/nonav/repository/),
> > >   objectweb-repo (http://maven.objectweb.org/maven2-snapshot)
> >
> > which kind of implies it did try to download it from central.
> It can also means that Maven prints the list of the known repositories.
>
> > > 3. Can I download this package from another source? I've tried to
> > > create build.properties file in my home directory with the property
> > > maven.repo.remote set to http://www.ibiblio.org/maven2/... But there
> > > was no changes...
> > I don't think build.properties is correct for Maven 2.  (it is for Maven 1).
> > Check the mirror information at:
> > http://maven.apache.org/guides/mini/guide-mirror-settings.html
> > and chose one that is closest to you.   That should help.
> I've tried to set mirror option in <MAVEN_HOME>/conf/settings.xml and
> then in <USER_HOME>/.m2/settings.xml but it does not help...
>
> > Alternatively, you could just download all the contents of
> >  http://repo1.maven.org/maven2/concurrent/concurrent/1.3.4/
> > and stick them in your ~/.m2/repository directory.   Maven is supposed to do
> > that automatically for you.
> I've downloaded concurent there and it helps. But then Maven failed
> while downloading commons-logging :(
>
> It seems that I really need some working method of setting new remote
> repositories...
I've marked mirror as a mirror of java.net instead of central and it works!

Daniel, thanks again for pointing me to the docs.

SY, Alexey

> > > 2006/7/14, Daniel Kulp <daniel.kulp@iona.com>:
> > > > The concurrent jar should be coming from "central":
> > > > http://repo1.maven.org/maven2/concurrent/concurrent/1.3.4/
> > > >
> > > > Most likely, the central repository was too busy and timed out.    I
> > > > would keep trying until it can get it downloaded.
> > > >
> > > > Dan
> > > >
> > > > On Friday July 14 2006 12:42 pm, Alexey Petrenko wrote:
> > > > > Hi, guys.
> > > > >
> > > > > I'm truying to build Yoko on Windows and I've faced a following
> > > > > problem...
> > > > >
> > > > > I've followed all the steps from the README.txt and got the following
> > > > > error after "mvn install" command:
> > > > >
> > > > > === cut ===
> > > > > installJars:
> > > > > [INFO] Executed tasks
> > > > > [INFO] [install:install]
> > > > > [INFO] Installing C:\Work\Harmony\yoko\sunjars\pom.xml to C:\Documents
> > > > > and
> > > > > Settings\aapetren\.m2\repository\org\apache\yoko\yoko-sunjars\1.0-incub
> > > > >atin g-M1-SNAPSHOT\yoko-sunjars-1.0-incubating-M1-SNAPSHOT.pom [INFO]
> > > > > -----------------------------------------------------------------------
> > > > >---- - [INFO] Building Yoko Core
> > > > > [INFO]    task-segment: [install]
> > > > > [INFO]
> > > > > -----------------------------------------------------------------------
> > > > >---- - [INFO] [resources:resources]
> > > > > [INFO] Using default encoding to copy filtered resources.
> > > > > Downloading:
> > > > > http://maven.objectweb.org/maven2-snapshot/concurrent/concurrent/1.3.4/
> > > > >conc urrent-1.3.4.pom [WARNING] Unable to get resource from repository
> > > > > objectweb-repo
> > > > > (http://maven.objectweb.org/maven2-snapshot)
> > > > > Downloading:
> > > > > https://maven-repository.dev.java.net/nonav/repository//concurrent/poms
> > > > >/con current-1.3.4.pom [INFO]
> > > > > -----------------------------------------------------------------------
> > > > >- [ERROR] BUILD ERROR
> > > > > [INFO]
> > > > > -----------------------------------------------------------------------
> > > > >- [INFO] Error building POM (may not be this project's POM).
> > > > >
> > > > >
> > > > > Project ID: concurrent:concurrent
> > > > >
> > > > > Reason: Error getting POM for 'concurrent:concurrent' from the
> > > > > repository: Error transferring file
> > > > >   concurrent:concurrent:pom:1.3.4
> > > > >
> > > > > from the specified remote repositories:
> > > > >   central (http://repo1.maven.org/maven2),
> > > > >   java.net (https://maven-repository.dev.java.net/nonav/repository/),
> > > > >   objectweb-repo (http://maven.objectweb.org/maven2-snapshot)
> > > > > === cut ===
> > > > >
> > > > > I've checked both the URLs
> > > > > (http://maven.objectweb.org/maven2-snapshot/concurrent/concurrent/1.3.4
> > > > >/con current-1.3.4.pom,
> > > > > https://maven-repository.dev.java.net/nonav/repository//concurrent/poms
> > > > >/con current-1.3.4.pom) and received 404 error in both cases.
> > > > >
> > > > > What am I doing wrong?
> > > > >
> > > > > Thanks in advance.
> > > > >
> > > > > SY, Alexey
> > > >
> > > > --
> > > > J. Daniel Kulp
> > > > Principal Engineer
> > > > IONA
> > > > P: 781-902-8727    C: 508-380-7194   F:781-902-8001
> > > > daniel.kulp@iona.com
> >
> > --
> > J. Daniel Kulp
> > Principal Engineer
> > IONA
> > P: 781-902-8727    C: 508-380-7194   F:781-902-8001
> > daniel.kulp@iona.com
> >
>
>
> --
> Alexey A. Petrenko
> Intel Middleware Products Division
>


-- 
Alexey A. Petrenko
Intel Middleware Products Division

Mime
View raw message