incubator-yoko-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anders Hessellund Jensen <...@trifork.com>
Subject Re: Java 1.5 compatibility...
Date Fri, 28 Jul 2006 12:22:21 GMT
Alexey Petrenko wrote:
> yoko-spec-corba looks like a subset of yoko-core... At least for
> package names...

> I did not quite understand what was the reason to duplicate the code.
> And do you synchronize it or not?

The intention was to separate the org.omg. classes (the API) from the 
yoko-specific classes. I wanted to remove the classes in org.omg. 
classes from the core project, but I was unable to set up the 
dependencies in maven correctly, since maven has no support for the 
endorsed standards override mechanism, which is why the yoko-spec-corba 
module is currently unused.

I think it is important to separate the org.omg. classes from the rest 
of the Yoko project. The people from Geronimo have expressed interest in 
this. It is important that Geronimo modules which depend on corba 
functionality can depend on the API only, and not a specific ORB 
implementation.

We really need a solution for this problem. I would have no problem with 
- as a temporary solution - to remove the yoko-spec-corba module and 
have the org.omg. classes in core until the maven issues can be resolved.

But i really think the spec  should be separated from Yoko eventually - 
as soon as possible, in fact.

Regards,
Anders

Mime
View raw message