incubator-yoko-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anders Hessellund Jensen <...@trifork.com>
Subject Re: Java 1.5 compatibility...
Date Fri, 28 Jul 2006 10:10:32 GMT
Alexey Petrenko wrote:
> so if nobody have any objections I'll start to tune org.omg packages
> of yoko-core to be binary compatible with Java 1.5...

Could you please clarify whether you are going to downgrade the 
org.omg.* packages to version supplied by Java 1.5 (CORBA 2.3.1), or are 
you going to modify them to be backwards compatible with CORBA 2.3.1?

I do not think it is a good idea to downgrade the org.omg.* classes.

I have created a separate module for the org.omg. packages, the 
yoko-spec-corba module. It is not in use yet, mostly because Maven is 
unable to handle it due to the conflicts with the JDK supplied org.omg. 
packages. Maven unfortunately has no support for the endorsed standards 
override mechanism.

I do think the work on the org.omg. classes should take place in the 
yoko-spec-corba package, however.

Regards,
Anders

Mime
View raw message