incubator-yoko-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <daniel.k...@iona.com>
Subject Re: [build] Yoko build problems
Date Fri, 14 Jul 2006 16:53:18 GMT
 
The concurrent jar should be coming from "central":
http://repo1.maven.org/maven2/concurrent/concurrent/1.3.4/

Most likely, the central repository was too busy and timed out.    I would 
keep trying until it can get it downloaded.

Dan



On Friday July 14 2006 12:42 pm, Alexey Petrenko wrote:
> Hi, guys.
>
> I'm truying to build Yoko on Windows and I've faced a following problem...
>
> I've followed all the steps from the README.txt and got the following
> error after "mvn install" command:
>
> === cut ===
> installJars:
> [INFO] Executed tasks
> [INFO] [install:install]
> [INFO] Installing C:\Work\Harmony\yoko\sunjars\pom.xml to C:\Documents
> and
> Settings\aapetren\.m2\repository\org\apache\yoko\yoko-sunjars\1.0-incubatin
>g-M1-SNAPSHOT\yoko-sunjars-1.0-incubating-M1-SNAPSHOT.pom [INFO]
> ---------------------------------------------------------------------------
>- [INFO] Building Yoko Core
> [INFO]    task-segment: [install]
> [INFO]
> ---------------------------------------------------------------------------
>- [INFO] [resources:resources]
> [INFO] Using default encoding to copy filtered resources.
> Downloading:
> http://maven.objectweb.org/maven2-snapshot/concurrent/concurrent/1.3.4/conc
>urrent-1.3.4.pom [WARNING] Unable to get resource from repository
> objectweb-repo
> (http://maven.objectweb.org/maven2-snapshot)
> Downloading:
> https://maven-repository.dev.java.net/nonav/repository//concurrent/poms/con
>current-1.3.4.pom [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Error building POM (may not be this project's POM).
>
>
> Project ID: concurrent:concurrent
>
> Reason: Error getting POM for 'concurrent:concurrent' from the
> repository: Error transferring file
>   concurrent:concurrent:pom:1.3.4
>
> from the specified remote repositories:
>   central (http://repo1.maven.org/maven2),
>   java.net (https://maven-repository.dev.java.net/nonav/repository/),
>   objectweb-repo (http://maven.objectweb.org/maven2-snapshot)
> === cut ===
>
> I've checked both the URLs
> (http://maven.objectweb.org/maven2-snapshot/concurrent/concurrent/1.3.4/con
>current-1.3.4.pom,
> https://maven-repository.dev.java.net/nonav/repository//concurrent/poms/con
>current-1.3.4.pom) and received 404 error in both cases.
>
> What am I doing wrong?
>
> Thanks in advance.
>
> SY, Alexey

-- 
J. Daniel Kulp
Principal Engineer
IONA
P: 781-902-8727    C: 508-380-7194   F:781-902-8001
daniel.kulp@iona.com

Mime
View raw message