incubator-yoko-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <daniel.k...@iona.com>
Subject Re: [jira] Commented: (YOKO-48) Tests in Core module fail on Windows
Date Tue, 09 May 2006 08:49:39 GMT

Before I comment about this in jira....


How is this a Maven bug?    I don't see anything specific to maven about 
it in the stack traces and such.    If the user installs "yoko binary 
distribution" into a directory with a space in it (like "Program Files"), 
would it fail as well?    All parts of yoko should be tolerant of spaces 
in the classpath.  

In anycase it needs to be fixed.   
Dan



On Tuesday 09 May 2006 02:20, Anders Hessellund Jensen (JIRA) wrote:
>     [
> http://issues.apache.org/jira/browse/YOKO-48?page=comments#action_12378
>574 ]
>
> Anders Hessellund Jensen commented on YOKO-48:
> ----------------------------------------------
>
> This is caused by a bug in Maven. The bug is triggered by the fact that
> there is spaces in the path to the maven repository, e.g. C:\Documents
> and Settings\ahj\.m2 . Apparently the translation to an URL for RMI
> fails somewhere.
>
> Workaround: Configure Maven to use a path without spaces, e.g.
> C:\.m2\repository
>
> There is a settings.xml file in maven-home/conf.settings.xml . Add the
> following:
>
> <settings>
>   <localRepository>c:/.m2/repository</localRepository>
> </settings>
>
> > Tests in Core module fail on Windows
> > ------------------------------------
> >
> >          Key: YOKO-48
> >          URL: http://issues.apache.org/jira/browse/YOKO-48
> >      Project: Yoko - CORBA Server
> >         Type: Task
> >
> >  Environment: Windows
> >     Reporter: Prasad Kosuru
> >     Priority: Blocker
> >
> >
> > After running mvn install command on windows the following exception
> > happens and the build hangs. [surefire] Running
> > org.apache.yoko.CodeSetTest
> > [client:err] Exception in thread "main" java.rmi.UnmarshalException:
> > error unmarshalling return; neste d exception is:
> > [client:err]    java.net.MalformedURLException: no protocol: and
> > [client:err]    at sun.rmi.registry.RegistryImpl_Stub.lookup(Unknown
> > Source) [client:err]    at
> > org.apache.yoko.processmanager.internal.ProcessAgentImpl.main(Process
> >AgentImpl.java
> >
> > :48)
> >
> > [client:err] Caused by: java.net.MalformedURLException: no protocol:
> > and [client:err]    at java.net.URL.<init>(URL.java:567)
> > [client:err]    at java.net.URL.<init>(URL.java:464)
> > [client:err]    at java.net.URL.<init>(URL.java:413)
> > [client:err]    at
> > sun.rmi.server.LoaderHandler.pathToURLs(LoaderHandler.java:747)
> > [client:err]    at
> > sun.rmi.server.LoaderHandler.loadProxyClass(LoaderHandler.java:505)
> > [client:err]    at
> > java.rmi.server.RMIClassLoader$2.loadProxyClass(RMIClassLoader.java:6
> >28) [client:err]    at
> > java.rmi.server.RMIClassLoader.loadProxyClass(RMIClassLoader.java:294
> >) [client:err]    at
> > sun.rmi.server.MarshalInputStream.resolveProxyClass(MarshalInputStrea
> >m.java:238) [client:err]    at
> > java.io.ObjectInputStream.readProxyDesc(ObjectInputStream.java:1494)
> > [client:err]    at
> > java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1457)
> > [client:err]    at
> > java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1
> >693) [client:err]    at
> > java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1299)
> > [client:err]    at
> > java.io.ObjectInputStream.readObject(ObjectInputStream.java:339)
> > [client:err]    ... 2 more
> > Alan suggested to install a fixed RMI class loader to resolve this.

-- 
J. Daniel Kulp
Principal Engineer
IONA
P: 781-902-8727  C: 508-380-7194
daniel.kulp@iona.com

Mime
View raw message