incubator-yoko-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan D. Cabrera" <l...@toolazydogs.com>
Subject Re: Resolution on JDK Layering - Alan's Proposal? (WAS:RE: coding standard and logging )
Date Sat, 22 Apr 2006 20:11:06 GMT
Nolan, Edell wrote:
> Hi,
>
> Sounds good to me and when geronimo has a release to fully support 
> jdk1.5 then a release of Yoko could be done to fully support jdk1.5 too.
>   
While Geronimo will support JDK15, it will still also support JDK14.  We 
must be mindful of that.


Regards,
Alan

> +1.
>
> Edell.
>
> -----Original Message-----
> From: Sakala, Adinarayana 
> Sent: 19 April 2006 18:07
> To: yoko-dev@incubator.apache.org
> Subject: Resolution on JDK Layering - Alan's Proposal? (WAS:RE: coding standard and logging
)
>
> Where do we stand on this JDK issue?
> I think i like Alan's layering proposal for the short term.
> Just to be clear,
>
>   trunk\core - compiles with JDK 1.4 and runs on both JDK 1.4 and 1.5
>
> Everything else i.e,
>
>   trunk\tools
>   trunk\bindings
>   ... compiles with JDK 1.5 and runs on JDK 1.5
>
> I think we should be able to setup maven build system to handle this automatically.
>
> In longer term, we could look at how we can introduce cool JDK 1.5 usage into core as
well.
>
> If nobody complains i suggest we implement this approach.
>
> thanks,
> Adi Sakala
>
>   
>> -----Original Message-----
>> From: Alan D. Cabrera [mailto:list@toolazydogs.com]
>> Sent: Thursday, April 06, 2006 6:12 PM
>> To: yoko-dev@incubator.apache.org
>> Subject: Re: coding standard and logging
>>
>>
>> Lars K├╝hne wrote, On 4/6/2006 2:16 PM:
>>
>>     
>>> Alan D. Cabrera wrote:
>>>
>>>       
>>>> Sakala, Adinarayana wrote, On 4/6/2006 12:15 PM:
>>>>
>>>>         
>>>>> Alan,
>>>>>
>>>>> when does geronimo move to JDK 1.5?
>>>>>  
>>>>>
>>>>>           
>>>> Geronimo is not moving to JDK15.  It will start supporting
>>>>         
>> JDK15 in
>>     
>>>> addition to JDK14.
>>>>         
>>>
>>> Pardon my ignorance, but won't J2EE 5 require running on a 1.5 JVM? 
>>> From JSR 244:
>>>
>>>    Java EE 5 is the Enterprise Edition of version 5 of the Java
>>>    platform, and thus will be built on J2SE 5.0.
>>>
>>>
>>> How will you implement the annotation features in J2EE 5 on
>>>       
>> a 1.4 JVM? 
>>
>>
>> You can layer the architecture to accommodate this.  This is what I am 
>> proposing for Yoko as well.
>>
>>
>> Regards,
>> Alan
>>
>>
>>
>>
>>     
>
>
>   


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message