incubator-wookie-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Wilson <scott.bradley.wil...@gmail.com>
Subject Re: Problem deploying webapp
Date Wed, 10 Aug 2011 10:42:05 GMT
On 9 Aug 2011, at 11:44, Lucas Anastasiou wrote:

> Hello Scott,
> 
> The database used is a completely new one, with a new user having all
> privilleges on it.
> 
> Below there is the full log when I start up tomcat:
> I can only see a warning on the logger initialization, could it be that and
> if yes how can i fix it?

No, I don't think that's the issue. See below...

> Aug 09, 2011 11:36:43 AM org.apache.catalina.core.AprLifecycleListener init
> INFO: Loaded APR based Apache Tomcat Native library 1.1.20.
> Aug 09, 2011 11:36:43 AM org.apache.catalina.core.AprLifecycleListener init
> INFO: APR capabilities: IPv6 [true], sendfile [true], accept filters
> [false], ra
> ndom [true].
> Aug 09, 2011 11:36:45 AM org.apache.coyote.AbstractProtocol init
> INFO: Initializing ProtocolHandler ["http-apr-8080"]
> Aug 09, 2011 11:36:45 AM org.apache.coyote.AbstractProtocol init
> INFO: Initializing ProtocolHandler ["ajp-apr-8009"]
> Aug 09, 2011 11:36:45 AM org.apache.catalina.startup.Catalina load
> INFO: Initialization processed in 1822 ms
> Aug 09, 2011 11:36:45 AM org.apache.catalina.core.StandardService
> startInternal
> INFO: Starting service Catalina
> Aug 09, 2011 11:36:45 AM org.apache.catalina.core.StandardEngine
> startInternal
> INFO: Starting Servlet Engine: Apache Tomcat/7.0.19
> Aug 09, 2011 11:36:45 AM org.apache.catalina.startup.HostConfig
> deployDescriptor
> 
> INFO: Deploying configuration descriptor wookie.xml from
> C:\apache-tomcat-7.0.19
> \conf\Catalina\localhost
> log4j:WARN No appenders could be found for logger
> (org.apache.commons.configurat
> ion.ConfigurationUtils).
> log4j:WARN Please initialize the log4j system properly.
> Aug 09, 2011 11:36:47 AM org.apache.catalina.core.StandardContext
> startInternal
> SEVERE: Error listenerStart
> Aug 09, 2011 11:36:47 AM org.apache.catalina.core.StandardContext
> startInternal
> SEVERE: Context [/wookie] startup failed due to previous errors
> Aug 09, 2011 11:36:47 AM org.apache.catalina.loader.WebappClassLoader
> clearRefer
> encesJdbc
> SEVERE: The web application [/wookie] registered the JDBC driver
> [com.mysql.jdbc
> .Driver] but failed to unregister it when the web application was stopped.
> To pr
> event a memory leak, the JDBC Driver has been forcibly unregistered.
> Aug 09, 2011 11:36:47 AM org.apache.catalina.startup.HostConfig
> deployDirectory
> INFO: Deploying web application directory docs
> Aug 09, 2011 11:36:47 AM org.apache.catalina.startup.HostConfig
> deployDirectory
> INFO: Deploying web application directory examples
> Aug 09, 2011 11:36:47 AM org.apache.catalina.startup.HostConfig
> deployDirectory
> INFO: Deploying web application directory host-manager
> Aug 09, 2011 11:36:47 AM org.apache.catalina.startup.HostConfig
> deployDirectory
> INFO: Deploying web application directory manager
> Aug 09, 2011 11:36:47 AM org.apache.catalina.startup.HostConfig
> deployDirectory
> INFO: Deploying web application directory ROOT
> Aug 09, 2011 11:36:47 AM org.apache.coyote.AbstractProtocol start
> INFO: Starting ProtocolHandler ["http-apr-8080"]
> Aug 09, 2011 11:36:47 AM org.apache.coyote.AbstractProtocol start
> INFO: Starting ProtocolHandler ["ajp-apr-8009"]
> Aug 09, 2011 11:36:47 AM org.apache.catalina.startup.Catalina start
> INFO: Server startup in 2395 ms
> 
> 
> 
> the build properties are
> 
> servletEngine.webapp.dir= C:\/apache-tomcat-7.0.19\/webapps\/
> servletEngine.container.lib.dir=C:\/apache-tomcat-7.0.19\/webapps\/wookie\/WEB-INF\/lib\/
> servletEngine.context.conf.dir=C:\/apache-tomcat-7.0.19\/conf\/Catalina\/localhost\/
> wookie.persistence.manager.type=jpa
> wookie.db.user=java
> wookie.db.password=java
> wookie.db.driver=com.mysql.jdbc.Driver
> wookie.db.uri=jdbc:mysql://localhost:3306/widgetdb
> wookie.db.type=mysql5
> jdbc.driver.path=mysql-connector-java-5.1.13-bin.jar

Does this driver jar actually exist (both in your deploy dir, and in tomcat lib dir)?

I've just tested a clean build with Tomcat 6.0.20 and 7.0.2, both with MySQL & connector
 5.0.7 and it worked fine.

> 
> 
> 
> Thanks,
> Lucas
> 
> 
> 
> 
> 
> On Mon, Aug 8, 2011 at 7:22 PM, Scott Wilson <scott.bradley.wilson@gmail.com
>> wrote:
> 
>> 
>> On 8 Aug 2011, at 17:29, Lucas Anastasiou wrote:
>> 
>>> Hi all,
>>> 
>>> I have been trying to deploy the latest version of wookie in a
>> tomcat/mysql
>>> configuration but I have been encountering the same problem over and over
>>> again:
>>> 
>>> [...]
>>> 
>>> Aug 08, 2011 4:56:37 PM org.apache.catalina.core.StandardContext
>>> startInternal
>>> *SEVERE: Error listenerStart*
>>> Aug 08, 2011 4:56:38 PM org.apache.catalina.util.SessionIdGenerator
>>> createSecure
>>> Random
>>> INFO: Creation of SecureRandom instance for session ID generation using
>>> [SHA1PRN
>>> G] took [149] milliseconds.
>>> Aug 08, 2011 4:56:38 PM org.apache.catalina.core.StandardContext
>>> startInternal
>>> *SEVERE: Context [/wookie] startup failed due to previous errors*
>>> 16:56:38,188  INFO JPAPersistenceManager:292 - Terminated
>>> 16:56:38,188  INFO PersistenceManagerFactory:346 - Terminated
>>> 
>>> [..]
>>> 
>> 
>> Can you scan further up the log to see if there are any detailed error
>> messages?
>> 
>> Also, did you already have a database still in place from an earlier build,
>> or did you drop the tables first? There were some schema changes in trunk a
>> while back.
>> 
>>> It seems to be the same problem with this one
>>> 
>> http://mail-archives.apache.org/mod_mbox/incubator-wookie-dev/201012.mbox/browser
>>> 
>>> I already tried a couple of things mentioned in this thread such as to
>> copy
>>> the <Resource> definition in "wookie.xml" file in /conf
>>> into /conf/context.xml,
>>> use openJDK instead of the sun/oracle JDK,
>>> different verisons of tomcat -  v6.0.32, v.7.0.19
>>> tried it on both windows 7/linux boxes
>>> 
>>> The database schema is created as expected (when setting the CATALINA
>>> options to initstore)  but webapp is never deployed - when i click
>>> localhost:8080/wookie I get a 404. I tried to (kick)start the webapp
>> through
>>> the tomcat manager with no success.
>>> 
>>> Do you guys have any ideas on what I am doing wrong?
>>> 
>>> Thanks in advance,
>>> Lucas
>> 
>> 


Mime
View raw message