incubator-wookie-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lucas Anastasiou <anast...@gmail.com>
Subject Re: Problem deploying webapp
Date Thu, 11 Aug 2011 13:08:16 GMT
On Thu, Aug 11, 2011 at 1:52 PM, Scott Wilson <
scott.bradley.wilson@gmail.com> wrote:

> On 11 Aug 2011, at 12:45, Lucas Anastasiou wrote:
>
> > Yes it exists both in [tomcat_home]/lib and
> > [tomcat_home]/webapps/wookie/WEB-INF/lib
> > Tried it also with the same connector you are using 5.0.7 (and not
> 5.1.13),
> > same tomcat version (7.0.2), still with no success.
> >
> > Could it be the mysql version (5.5.8)? Should I try to downgrade?
> >
> > Could it be that my box is 64bit - some kind of weird incompatibility
> with
> > drivers used?(ok, longshot guess but I am starting to run out of
> ideas...)
>
> I just checked and I'm using MySQL 5.0.45. But it shouldn't really matter
> as long as the connector and server are compatible. (I use connector 5.1.13
> normally too, I just somehow deleted it and so used another version I had a
> jar for on my system).
>
> Just FYI, here are the build.properties I'm using:
>
> version=0.9.1-SNAPSHOT
>
> # Run arguments to use when running in developer mode
> run.args="port=8080"
>
> # Uncomment to include Extra features
> include.extra.features
> # Uncomment to include Scratchpad features
> include.scratchpad.features
>
> # Uncomment to include Extra widgets
> include.extra.widgets
> # Uncomment to include Scratchpad widgets
> include.scratchpad.widgets
>
> # The location of your servlets webapp directory, (required: defaults to
> location for
> # standalone server)
> servletEngine.webapp.dir=build/webapp
>
>
Is this correct? Shouldn't it be
[tomcat_home]/webapps

Wookie runs ok in standalone mode but it just refuses to deploy correctly as
webapp

Could it be that ivy uses an older version of one of the libraries jar
files? How can I ensure that ivy downloads a fresh version of all the
libraries jar files and not a cached version?


> # The location of your container lib directory, (required for deployed
> non-standalone
> # configurations)
> servletEngine.container.lib.dir=/usr/local/apache-tomcat-7.0.2/lib
>
> # The location of your tomcat container webapp context configuration
> directory, (required
> # for deployed non-standalone configurations; requires configuration of
> wookie.db.user,
> # wookie.db.password, wookie.db.driver, wookie.db.uri, and jdbc.driver.path
> properties below
> # for JPA JDBC configurations)
> servletEngine.context.conf.dir=/usr/local/apache-tomcat-7.0.2/conf
>
> # Generic JPA JDBC server configuration; supported database types: db2,
> derby, hsqldb, mssql,
> # mysql, mysql5, oracle, oracle9, oracle10, postgresql, and sybase; (all
> properties required
> # for deployed non-standalone configurations)
> wookie.persistence.manager.type=jpa
> wookie.db.user=java
> wookie.db.password=java
> wookie.db.driver=com.mysql.jdbc.Driver
> wookie.db.uri=jdbc:mysql://localhost:3306/widgetdb
> wookie.db.type=mysql
> jdbc.driver.path=mysql-connector-java-5.0.7-bin.jar
>
>
> >
> > Lucas
> >
> > On Wed, Aug 10, 2011 at 11:42 AM, Scott Wilson <
> > scott.bradley.wilson@gmail.com> wrote:
> >
> >> On 9 Aug 2011, at 11:44, Lucas Anastasiou wrote:
> >>
> >>> Hello Scott,
> >>>
> >>> The database used is a completely new one, with a new user having all
> >>> privilleges on it.
> >>>
> >>> Below there is the full log when I start up tomcat:
> >>> I can only see a warning on the logger initialization, could it be that
> >> and
> >>> if yes how can i fix it?
> >>
> >> No, I don't think that's the issue. See below...
> >>
> >>> Aug 09, 2011 11:36:43 AM org.apache.catalina.core.AprLifecycleListener
> >> init
> >>> INFO: Loaded APR based Apache Tomcat Native library 1.1.20.
> >>> Aug 09, 2011 11:36:43 AM org.apache.catalina.core.AprLifecycleListener
> >> init
> >>> INFO: APR capabilities: IPv6 [true], sendfile [true], accept filters
> >>> [false], ra
> >>> ndom [true].
> >>> Aug 09, 2011 11:36:45 AM org.apache.coyote.AbstractProtocol init
> >>> INFO: Initializing ProtocolHandler ["http-apr-8080"]
> >>> Aug 09, 2011 11:36:45 AM org.apache.coyote.AbstractProtocol init
> >>> INFO: Initializing ProtocolHandler ["ajp-apr-8009"]
> >>> Aug 09, 2011 11:36:45 AM org.apache.catalina.startup.Catalina load
> >>> INFO: Initialization processed in 1822 ms
> >>> Aug 09, 2011 11:36:45 AM org.apache.catalina.core.StandardService
> >>> startInternal
> >>> INFO: Starting service Catalina
> >>> Aug 09, 2011 11:36:45 AM org.apache.catalina.core.StandardEngine
> >>> startInternal
> >>> INFO: Starting Servlet Engine: Apache Tomcat/7.0.19
> >>> Aug 09, 2011 11:36:45 AM org.apache.catalina.startup.HostConfig
> >>> deployDescriptor
> >>>
> >>> INFO: Deploying configuration descriptor wookie.xml from
> >>> C:\apache-tomcat-7.0.19
> >>> \conf\Catalina\localhost
> >>> log4j:WARN No appenders could be found for logger
> >>> (org.apache.commons.configurat
> >>> ion.ConfigurationUtils).
> >>> log4j:WARN Please initialize the log4j system properly.
> >>> Aug 09, 2011 11:36:47 AM org.apache.catalina.core.StandardContext
> >>> startInternal
> >>> SEVERE: Error listenerStart
> >>> Aug 09, 2011 11:36:47 AM org.apache.catalina.core.StandardContext
> >>> startInternal
> >>> SEVERE: Context [/wookie] startup failed due to previous errors
> >>> Aug 09, 2011 11:36:47 AM org.apache.catalina.loader.WebappClassLoader
> >>> clearRefer
> >>> encesJdbc
> >>> SEVERE: The web application [/wookie] registered the JDBC driver
> >>> [com.mysql.jdbc
> >>> .Driver] but failed to unregister it when the web application was
> >> stopped.
> >>> To pr
> >>> event a memory leak, the JDBC Driver has been forcibly unregistered.
> >>> Aug 09, 2011 11:36:47 AM org.apache.catalina.startup.HostConfig
> >>> deployDirectory
> >>> INFO: Deploying web application directory docs
> >>> Aug 09, 2011 11:36:47 AM org.apache.catalina.startup.HostConfig
> >>> deployDirectory
> >>> INFO: Deploying web application directory examples
> >>> Aug 09, 2011 11:36:47 AM org.apache.catalina.startup.HostConfig
> >>> deployDirectory
> >>> INFO: Deploying web application directory host-manager
> >>> Aug 09, 2011 11:36:47 AM org.apache.catalina.startup.HostConfig
> >>> deployDirectory
> >>> INFO: Deploying web application directory manager
> >>> Aug 09, 2011 11:36:47 AM org.apache.catalina.startup.HostConfig
> >>> deployDirectory
> >>> INFO: Deploying web application directory ROOT
> >>> Aug 09, 2011 11:36:47 AM org.apache.coyote.AbstractProtocol start
> >>> INFO: Starting ProtocolHandler ["http-apr-8080"]
> >>> Aug 09, 2011 11:36:47 AM org.apache.coyote.AbstractProtocol start
> >>> INFO: Starting ProtocolHandler ["ajp-apr-8009"]
> >>> Aug 09, 2011 11:36:47 AM org.apache.catalina.startup.Catalina start
> >>> INFO: Server startup in 2395 ms
> >>>
> >>>
> >>>
> >>> the build properties are
> >>>
> >>> servletEngine.webapp.dir= C:\/apache-tomcat-7.0.19\/webapps\/
> >>>
> >>
> servletEngine.container.lib.dir=C:\/apache-tomcat-7.0.19\/webapps\/wookie\/WEB-INF\/lib\/
> >>>
> >>
> servletEngine.context.conf.dir=C:\/apache-tomcat-7.0.19\/conf\/Catalina\/localhost\/
> >>> wookie.persistence.manager.type=jpa
> >>> wookie.db.user=java
> >>> wookie.db.password=java
> >>> wookie.db.driver=com.mysql.jdbc.Driver
> >>> wookie.db.uri=jdbc:mysql://localhost:3306/widgetdb
> >>> wookie.db.type=mysql5
> >>> jdbc.driver.path=mysql-connector-java-5.1.13-bin.jar
> >>
> >> Does this driver jar actually exist (both in your deploy dir, and in
> tomcat
> >> lib dir)?
> >>
> >> I've just tested a clean build with Tomcat 6.0.20 and 7.0.2, both with
> >> MySQL & connector  5.0.7 and it worked fine.
> >>
> >>>
> >>>
> >>>
> >>> Thanks,
> >>> Lucas
> >>>
> >>>
> >>>
> >>>
> >>>
> >>> On Mon, Aug 8, 2011 at 7:22 PM, Scott Wilson <
> >> scott.bradley.wilson@gmail.com
> >>>> wrote:
> >>>
> >>>>
> >>>> On 8 Aug 2011, at 17:29, Lucas Anastasiou wrote:
> >>>>
> >>>>> Hi all,
> >>>>>
> >>>>> I have been trying to deploy the latest version of wookie in a
> >>>> tomcat/mysql
> >>>>> configuration but I have been encountering the same problem over
and
> >> over
> >>>>> again:
> >>>>>
> >>>>> [...]
> >>>>>
> >>>>> Aug 08, 2011 4:56:37 PM org.apache.catalina.core.StandardContext
> >>>>> startInternal
> >>>>> *SEVERE: Error listenerStart*
> >>>>> Aug 08, 2011 4:56:38 PM org.apache.catalina.util.SessionIdGenerator
> >>>>> createSecure
> >>>>> Random
> >>>>> INFO: Creation of SecureRandom instance for session ID generation
> using
> >>>>> [SHA1PRN
> >>>>> G] took [149] milliseconds.
> >>>>> Aug 08, 2011 4:56:38 PM org.apache.catalina.core.StandardContext
> >>>>> startInternal
> >>>>> *SEVERE: Context [/wookie] startup failed due to previous errors*
> >>>>> 16:56:38,188  INFO JPAPersistenceManager:292 - Terminated
> >>>>> 16:56:38,188  INFO PersistenceManagerFactory:346 - Terminated
> >>>>>
> >>>>> [..]
> >>>>>
> >>>>
> >>>> Can you scan further up the log to see if there are any detailed error
> >>>> messages?
> >>>>
> >>>> Also, did you already have a database still in place from an earlier
> >> build,
> >>>> or did you drop the tables first? There were some schema changes in
> >> trunk a
> >>>> while back.
> >>>>
> >>>>> It seems to be the same problem with this one
> >>>>>
> >>>>
> >>
> http://mail-archives.apache.org/mod_mbox/incubator-wookie-dev/201012.mbox/browser
> >>>>>
> >>>>> I already tried a couple of things mentioned in this thread such
as
> to
> >>>> copy
> >>>>> the <Resource> definition in "wookie.xml" file in /conf
> >>>>> into /conf/context.xml,
> >>>>> use openJDK instead of the sun/oracle JDK,
> >>>>> different verisons of tomcat -  v6.0.32, v.7.0.19
> >>>>> tried it on both windows 7/linux boxes
> >>>>>
> >>>>> The database schema is created as expected (when setting the CATALINA
> >>>>> options to initstore)  but webapp is never deployed - when i click
> >>>>> localhost:8080/wookie I get a 404. I tried to (kick)start the webapp
> >>>> through
> >>>>> the tomcat manager with no success.
> >>>>>
> >>>>> Do you guys have any ideas on what I am doing wrong?
> >>>>>
> >>>>> Thanks in advance,
> >>>>> Lucas
> >>>>
> >>>>
> >>
> >>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message