incubator-whirr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom White <...@cloudera.com>
Subject Re: Notice: recently I checked out from svn and ClusterSpecTest.testDefaultsPublicKey() failed becaue
Date Fri, 24 Dec 2010 00:11:21 GMT
Thanks for reporting this Tibor. I hope this case will be covered by
https://issues.apache.org/jira/browse/WHIRR-164.

Cheers
Tom

On Mon, Dec 20, 2010 at 8:32 AM, Kiss Tibor <kiss.tibor@gmail.com> wrote:
> Hi!
>
> This is not a bug, but worst considering.. maybe somebody else will fall in
> the same situation..
>
> Recently I checked out from svn and ClusterSpecTest.testDefaultsPublicKey()
> fails because  it is set only the whirr.private-key-file (also there is a
> comment
> // If no public-key-file is specified it should append .pub to the
> private-key-file )
> Then in ClusterSpec init it is selected the correct newly generated private
> key (in privateKeyPath) , but the public key is selected from my home
> directory.
>
>       String publicKeyPath =
> c.getString(Property.PUBLIC_KEY_FILE.getConfigName());
>       publicKeyPath = (publicKeyPath == null && privateKeyPath != null)
?
>                 privateKeyPath + ".pub" : publicKeyPath;
>
> Unfortunately the publicKeyPath is not null and as a result does not select
> the privateKeyPath+".pub".
>
> The cause of why I had a value in
> c.getString(Property.PUBLIC_KEY_FILE.getConfigName()) it was that
> accidentally I left a ~/whirr-default.properties I played with some days ago
> from where the ClusterSpec it was initialized!
>
> After removing that ~/whirr-default.propertie, everything was fine. I shared
> this info, maybe somebody else falls in the same configuration issue...
>
> Cheers,
> Tibor Kiss
>

Mime
View raw message