incubator-wave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yuri Z <vega...@gmail.com>
Subject Re: warning/error when compiling on windows 7 with java 1.7.0_79
Date Mon, 07 Dec 2015 16:10:18 GMT
Did you edit server.config?

On Mon, Dec 7, 2015 at 5:40 PM Ian Dunlop <ianwdunlop@gmail.com> wrote:

> Hello,
>
> I had to set JAVA_HOME to use the 1.7 jdk, not just the Path. Thanks for
> the hints :) Been a while since I have used ant. However, I seem to have
> some test failures
> in org.waveprotocol.box.server.persistence.file
>
> <file:///C:/Users/idunlop/code/incubator-wave/test_out/org/waveprotocol/box/server/persistence/file/package-summary.html>.
> All seem to fail with:
> "String: 1: Expecting end of input or a comma, got ':' (if you intended ':'
> to be part of the value for 'core.attachment_store_directory', try
> enclosing the value in double quotes)".
>
> eg
> com.typesafe.config.ConfigException$Parse: String: 1: Expecting end of
> input or a comma, got ':' (if you intended ':' to be part of the value for
> 'core.attachment_store_directory', try enclosing the value in double
> quotes)
> at com.typesafe.config.impl.Parser$ParseContext.parseError(Parser.java:435)
>
> at
> com.typesafe.config.impl.Parser$ParseContext.parseError(Parseer.java:431)
> at
> com.typesafe.config.impl.Parser$ParseContext.parseObject(Parser.java:887)
> at com.typesafe.config.impl.Parser$ParseContext.parse(Parser.java:993)
> at com.typesafe.config.impl.Parser.parse(Parser.java:34)
> at com.typesafe.config.impl.Parseable.rawParseValue(Parseable.java:222)
> at com.typesafe.config.impl.Parseable.rawParseValue(Parseable.java:210)
> at com.typesafe.config.impl.Parseable.parseValue(Parseable.java:176)
> at com.typesafe.config.impl.Parseable.parseValue(Parseable.java:170)
> at com.typesafe.config.impl.Parseable.parse(Parseable.java:227)
> at com.typesafe.config.ConfiggFactory.parseString(ConfigFactory.java:823)
> at com.typesafe.config.ConfigFactory.parseString(ConfigFactory.java:827)
> at
>
> org.wwaveprotocol.box.server.persistence.file.AttachmentStoreTest.newAttachmentStore(AttachmentStoreTest.java:43)
> at
>
> org.waveprotocol.box.server.persistence.AttachmentStoreTestBase.makeStoreWithData(AttachmentStoreTestBase.java:175)
> at
>
> orgg.waveprotocol.box.server.persistence.AttachmentStoreTestBase.testContentLengthMatchesDataSize(AttachmentStoreTestBase.java:60)
>
> Cheers,
>
> Ian
>
> On 7 December 2015 at 13:59, Yuri Z <vega113@gmail.com> wrote:
>
> > Are you sure you compile with java 1.7?
> >
> > On Mon, Dec 7, 2015 at 3:19 PM Ian Dunlop <ianwdunlop@gmail.com> wrote:
> >
> > > Hello,
> > >
> > > I did 'ant clean' then 'ant'. Got the same result. I then tried 'ant
> > > get-third-party compile-gwt dist-server' but it still failed with the
> > same
> > > issues. Do I need to try a different command with ant?
> > >
> > > Cheers,
> > >
> > > Ian
> > >
> > > On 7 December 2015 at 12:26, Evan Hughes <ehugh1@gmail.com> wrote:
> > >
> > > > Ian just to make sure can you do a ant clean and remove the 3rd party
> > and
> > > > try again, also let us know which commands you were running to make
> > this.
> > > >
> > > > On 7 December 2015 at 22:01, Ian Dunlop <ianwdunlop@gmail.com>
> wrote:
> > > >
> > > > > Hello,
> > > > >
> > > > > Having problems building wave with java 1.7.0_79 and ant 1.9.6 on
> > > windows
> > > > > 7. Stack trace below. Fails when compiling wave-api. Seems to be
a
> > > > warning
> > > > > with regards to generics. Any ideas?
> > > > >
> > > > > Cheers,
> > > > >
> > > > > Ian
> > > > >
> > > > > compile:
> > > > >      [echo] Compiling wave-api-0.6.0
> > > > >     [javac] Compiling 37 source files to
> > > > > C:\Users\idunlop\code\incubator-wave\build\src
> > > > >     [javac]
> > > > >
> > > > >
> > > >
> > >
> >
> C:\Users\idunlop\code\incubator-wave\src\org\waveprotocol\wave\model\document\ObservableMutableDocument.java
> > > > > :54: warning: [overloads]
> > > > >
> > > >
> > >
> >
> with(org.waveprotocol.wave.model.document.ObservableMutableDocument.Action)
> > > > > in ObservableMutableDocument is potentially ambiguous with
> > > > > with(org.waveprotocol.wave.model.document.MutableDocument.Action)
> in
> > > > > MutableDoc
> > > > > ument
> > > > >     [javac]   public void with(Action
> > > > > actionToRunWithObservableMutableDocument);
> > > > >     [javac]               ^
> > > > >     [javac]
> > > > >
> > > > >
> > > >
> > >
> >
> C:\Users\idunlop\code\incubator-wave\src\org\waveprotocol\wave\model\document\ObservableMutableDocument.java
> > > > > :55: warning: [overloads]
> > > > >
> > > > >
> > > >
> > >
> >
> <V#1>with(org.waveprotocol.wave.model.document.ObservableMutableDocument.Method<V#1>)
> > > > > in ObservableMutableDocument is potentially ambiguous with
> > > > >
> <V#2>with(org.waveprotocol.wave.model.document.MutableDocument.Method
> > > > > <V#2>) in MutableDocument
> > > > >     [javac]   public <V> V with(Method<V>
> > > > methodToRunWithMutableDocument);
> > > > >     [javac]                ^
> > > > >     [javac]   where V#1,V#2 are type-variables:
> > > > >     [javac]     V#1 extends Object declared in method
> > > > > <V#1>with(org.waveprotocol.wave.model.document.ObservableMutableDo
> > > > > cument.Method<V#1>)
> > > > >     [javac]     V#2 extends Object declared in method
> > > > > <V#2>with(org.waveprotocol.wave.model.document.MutableDocument.Met
> > > > > hod<V#2>)
> > > > >     [javac] error: warnings found and -Werror specified
> > > > >     [javac] 1 error
> > > > >     [javac] 2 warnings
> > > > >
> > > > > BUILD FAILED
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message