incubator-wave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Wrobel <darkfl...@gmail.com>
Subject Re: Setting up Wave for client development (my experience setting up on WindowsXP)
Date Sat, 07 Dec 2013 23:20:30 GMT
I can see screenshots, at least, some. Regarding compile times, java
compliance level and the compile errors if you dont set it.

~~~
Thomas & Bertines online review show:
http://randomreviewshow.com/index.html
Try it! You might even feel ambivalent about it :)


On 7 December 2013 23:49, Ali Lown <ali@lown.me.uk> wrote:

> Attachments are dropped by the list.
>
> Ali
> On 7 Dec 2013 22:28, "Frank R." <renfeng.cn@gmail.com> wrote:
>
> > On Sat, Dec 7, 2013 at 10:02 PM, Thomas Wrobel <darkflame@gmail.com>
> > wrote:
> >
> > > Fantastic work there.
> > > For the moment, I am going to continue trying to set it up properly -
> and
> > > making notes to update/clarify the guide as appropriate, but its good
> to
> > > have that as a fallback.
> > >
> > > Currently still trying to get the client running;
> > >
> > > >>you need to create a debug/run configuration with arguments set
> > properly.
> > > >>you can find the arguments by reading run.sh
> > >
> > > I assume you mean "run-server.sh" (or-import or -export). I don't see
> > just
> > > a "run.sh".
> > >
> > Sorry for the typo. run-server.sh
> >
> >
> > > Then again, I couldn't find any obvious arguments for the client in
> those
> > > files either.
> > >
> > > If anyone here is using eclipse could give me a screenshot of their run
> > > settings?
> > >
> > Can you see the screenshots attached to my previous emails? Can anyone?
> >
> >
> > >
> > > Alternatively, just let me know what the html file is the webclient is
> > > supposed to be using as thats what it doesnt seem to know.
> Overall.html?
> > > Index.html? frame.html?
> > >
> > >
> > >
> > >
> > > ~~~
> > > Thomas & Bertines online review show:
> > > http://randomreviewshow.com/index.html
> > > Try it! You might even feel ambivalent about it :)
> > >
> > >
> > > On 7 December 2013 12:25, Frank R. <renfeng.cn@gmail.com> wrote:
> > >
> > > > Here is the OVA ready for downloading.
> > > >  wave-dev-on-cinnamon.ova<
> > > >
> > >
> >
> https://docs.google.com/file/d/0B_OYKagpJexmdG5QYzhZeC1QNTg/edit?usp=drive_web
> > > > >
> > > >
> > > >
> > > >
> > > > On Sat, Dec 7, 2013 at 7:18 PM, Fleeky Flanco <fleeky@gmail.com>
> > wrote:
> > > >
> > > > > frank,
> > > > >
> > > > > thats pretty awesome, my only question is why you used LM 13 and
> not
> > > say
> > > > a
> > > > > debian cmd line only distro?
> > > > >
> > > > Because, it would be a development box with JDK, Ant, Eclipse, Solr,
> > and
> > > > source code preinstalled and ready to use, i.e. ready for a developer
> > to
> > > > start in a matter of seconds. It's for you to start playing with the
> > > code,
> > > > rather than simply a demo server.
> > > >
> > > >
> > > > >
> > > > > either way nice work :)
> > > > >
> > > > >
> > > > > On Sat, Dec 7, 2013 at 6:16 AM, Frank R. <renfeng.cn@gmail.com>
> > wrote:
> > > > >
> > > > > > I've created a vm. Now, I'm uploading it to Google Drive for
> > sharing.
> > > > > >
> > > > > > Here is the log of how I made it.
> > > > > >  wave-dev-on-cinnamon<
> > > > >
> > > >
> > >
> >
> https://docs.google.com/document/d/1iGFLmAzi3SaEH0J6SNlaq6wubesRWlO2A8bvqxPp-p4/edit?usp=drive_web
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > On Thu, Dec 5, 2013 at 3:59 PM, Frank R. <renfeng.cn@gmail.com>
> > > wrote:
> > > > > >
> > > > > >>
> > > > > >>
> > > > > >>
> > > > > >> On Thu, Dec 5, 2013 at 3:24 AM, Thomas Wrobel <
> > darkflame@gmail.com
> > > > > >wrote:
> > > > > >>
> > > > > >>> "BUILD SUCCESSFUL
> > > > > >>> Total time: 312 minutes 41 seconds"
> > > > > >>>
> > > > > >>> Ok, after giving Oracle my "totally real" address and
"totally
> > > real"
> > > > > >>> phone
> > > > > >>> number I got JDK6 and now Ant is building just fine.
> > > > > >>> After 5-6 hours its done.
> > > > > >>> (hours? is that normal? my machines not that great but
> still...)
> > > > > >>>
> > > > > >> What is the configuration of your PC?
> > > > > >>
> > > > > >> It took me 3 minutes 26 seconds to compile gwt. You can
read
> more
> > > > > details
> > > > > >> in a log for how I explored the build process on Linux Mint
13 -
> > > > Making
> > > > > >> of Start your own Wave in a Box - Google Drive<
> > > > >
> > > >
> > >
> >
> https://docs.google.com/document/d/1uFzLD6gyY-L5egbztn9FFJjoyWvf3uO3AYnJoSMiTis/edit#
> > > > > >.
> > > > > >> And the slides, Start your own Wave in a Box - Google Drive<
> > > > >
> > > >
> > >
> >
> https://docs.google.com/presentation/d/1k2KqC_h0cU_7Xpgfya8W2B2REkxb_YsQQWL5zBGE-ac/pub?start=false&loop=false&delayms=3000
> > > > > >.
> > > > > >> Hope that will help.
> > > > > >>      [java]    Compile of permutations succeeded
> > > > > >>      [java] Linking into /tmp/wave/war/webclient
> > > > > >>      [java]    Link succeeded
> > > > > >>      [java]    Compilation succeeded -- 204.776s
> > > > > >>     [touch] Creating /tmp/wave/build/dep/compile-gwt
> > > > > >>
> > > > > >> BUILD SUCCESSFUL
> > > > > >> Total time: 3 minutes 26 seconds
> > > > > >>
> > > > > >>
> > > > > >>>
> > > > > >>> Suggestion;
> > > > > >>> Would it be possible to have a virtual machine with
everything
> > set
> > > up
> > > > > >>> already? or is there technical/license reasons for that
to be
> > > > > unsuitable?
> > > > > >>>
> > > > > >> I can do that by creating a virtual box image, and exporting
it
> as
> > > OVA
> > > > > >> file - Open Virtualization Archive, the single-file version
of
> an
> > > Open
> > > > > >> Virtualization Format<
> > > > > http://en.wikipedia.org/wiki/Open_Virtualization_Format>image.
> It'll
> > > > > resemble my Linux Mint box.
> > > > > >>
> > > > > >>
> > > > > >>> Query:
> > > > > >>> Can Wave be updated to JDK7? is there big issues holding
it
> back
> > ?
> > > Or
> > > > > is
> > > > > >>> there more open alternatives we can use instead - one
that
> > doesn't
> > > > > >>> require
> > > > > >>> handing over personal details to a company?
> > > > > >>
> > > > > >> You can have JDK7 to compile and run Wave in a Box. I guess
the
> > > trick
> > > > > >> should be that compiler compliance level must be 1.6. I
used to
> be
> > > > > troubled
> > > > > >> by the problem occasionally. I need to verify that.
> > > > > >>
> > > > > >> Now, I have both 7 and 6 on my Windows 7 box.
> > > > > >> [image: Inline image 1]
> > > > > >>
> > > > > >> I have the runtime as Java 6. I don't know how I get such
> settings
> > > > after
> > > > > >> upgrading JRE and JDK several times, and removing obsolete
> > versions.
> > > > > >> [image: Inline image 2]
> > > > > >>
> > > > > >> However, my Ant is running on Java 7. I can have a
> > clean-and-release
> > > > > >> build.
> > > > > >> [image: Inline image 3]
> > > > > >>
> > > > > >> When I have Wave in a Box loaded in Eclipse, I have to make
sure
> > the
> > > > > >> compiler compliance level to be 1.6.
> > > > > >> [image: Inline image 5]
> > > > > >>
> > > > > >> Or else, I'll have a bunch of compile errors.
> > > > > >> [image: Inline image 4]
> > > > > >>
> > > > > >>
> > > > > >>
> > > > > >>
> > > > > >>> --
> > > > > >>> If we want to get more people into Wave development,
at my
> > > experience
> > > > > >>> here
> > > > > >>> is the norm, then these might be significant issues.
Possibly
> > > more-so
> > > > > >>> then
> > > > > >>> Apache vs Git.
> > > > > >>>
> > > > > >>> Regardless, I'll continue my experiences trying to get
started.
> > ho
> > > > hum.
> > > > > >>>
> > > > > >>>
> > > > > >>>
> > > > > >>>
> > > > > >>>
> > > > > >>> ~~~
> > > > > >>> Thomas & Bertines online review show:
> > > > > >>> http://randomreviewshow.com/index.html
> > > > > >>> Try it! You might even feel ambivalent about it :)
> > > > > >>>
> > > > > >>>
> > > > > >>> On 2 December 2013 23:25, Thomas Wrobel <darkflame@gmail.com>
> > > wrote:
> > > > > >>>
> > > > > >>> > bah...need to sign up to Oracle just to download
JDK6 now?
> > > > seriously
> > > > > >>> >_<
> > > > > >>> > This is the sort of thing that puts people off
:-/
> > > > > >>> > *files it under "do tommorow"
> > > > > >>> >
> > > > > >>> > ~~~
> > > > > >>> > Thomas & Bertines online review show:
> > > > > >>> > http://randomreviewshow.com/index.html
> > > > > >>> > Try it! You might even feel ambivalent about it
:)
> > > > > >>> >
> > > > > >>> >
> > > > > >>> > On 2 December 2013 22:10, Thomas Wrobel <darkflame@gmail.com
> >
> > > > wrote:
> > > > > >>> >
> > > > > >>> >> ah...no...a fresh download of jdk7
> > > > > >>> >> I'll downgrade.
> > > > > >>> >>
> > > > > >>> >> ~~~
> > > > > >>> >> Thomas & Bertines online review show:
> > > > > >>> >> http://randomreviewshow.com/index.html
> > > > > >>> >> Try it! You might even feel ambivalent about
it :)
> > > > > >>> >>
> > > > > >>> >>
> > > > > >>> >> On 2 December 2013 21:39, Ali Lown <ali@lown.me.uk>
wrote:
> > > > > >>> >>
> > > > > >>> >>> Are you definitely using jdk6?
> > > > > >>> >>> On 2 Dec 2013 20:25, "Thomas Wrobel" <darkflame@gmail.com>
> > > > wrote:
> > > > > >>> >>>
> > > > > >>> >>> > Thanks - I'll use that one as a reference
now, but I'll
> aim
> > > to
> > > > > >>> >>> edit/update
> > > > > >>> >>> > the other one (as that seems a bit
more "friendly" for
> > > someone
> > > > > >>> getting
> > > > > >>> >>> > started).
> > > > > >>> >>> > ---
> > > > > >>> >>> > Notes #4:
> > > > > >>> >>> > ant get-third-party is needed before
running ant.
> > > > > >>> >>> > --- Stuck #4:
> > > > > >>> >>> > Build error;
> > > > > >>> >>> > C:\TomsProjects\wave>ant Buildfile:
> > > > > C:\TomsProjects\wave\build.xml
> > > > > >>> >>> > check-test-dependencies: init-logging:
[mkdir] Created
> dir:
> > > > > >>> >>> > C:\TomsProjects\wave\build\logs [echo]
Logging to
> > > > > >>> >>> > C:\TomsProjects\wave/build/logs/build_2013-11-29_17-48-35
> > > .log
> > > > > >>> init:
> > > > > >>> >>> > [mkdir] Created dir: C:\TomsProjects\wave\build\proto
> > [mkdir]
> > > > > >>> Created
> > > > > >>> >>> dir:
> > > > > >>> >>> > C:\TomsProjects\wave\build\messages
[mkdir] Created dir:
> > > > > >>> >>> > C:\TomsProjects\wave\build\src [mkdir]
Created dir:
> > > > > >>> >>> > C:\TomsProjects\wave\build\test [mkdir]
Created dir:
> > > > > >>> >>> > C:\TomsProjects\wave\build\coverage
[mkdir] Created dir:
> > > > > >>> >>> > C:\TomsProjects\wave\dist [mkdir]
Created dir:
> > > > > >>> >>> > C:\TomsProjects\wave\build\staging
[mkdir] Created dir:
> > > > > >>> >>> > C:\TomsProjects\wave\build\dep [mkdir]
Created dir:
> > > > > >>> >>> > C:\TomsProjects\wave\test_out compile-proto-dep:
> > > compile-proto:
> > > > > >>> [javac]
> > > > > >>> >>> > Compiling 12 source files to
> > C:\TomsProjects\wave\build\proto
> > > > > >>> [javac]
> > > > > >>> >>> >
> > > > > >>>
> > > C:\TomsProjects\wave\proto_src\org\waveprotocol\box\attachment\Attac
> > > > > >>> >>> > hmentProto.java:344: warning: [static]
static method
> should
> > > be
> > > > > >>> >>> qualified by
> > > > > >>> >>> > type name, Builder, instead of by
an expression [javac]
> > > > > >>> >>> > super.addAll(values, result.attachment_);
[javac] ^
> [javac]
> > > > > error:
> > > > > >>> >>> warnings
> > > > > >>> >>> > found and -Werror specified [javac]
> > > > > >>> >>> >
> > > > > >>>
> > > C:\TomsProjects\wave\proto_src\org\waveprotocol\box\common\comms\Wav
> > > > > >>> >>> > eClientRpc.java:990: warning: [static]
static method
> should
> > > be
> > > > > >>> >>> qualified by
> > > > > >>> >>> > type name, Builder, instead of by
an expression [javac]
> > > > > >>> >>> > super.addAll(values, result.waveletIdPrefix_);
[javac] ^
> > > > > >>> >>> > ...(and a lot of similiar warnings
ending in a ...
> > > > > >>> >>> >
> > > > > >>> >>> >     [javac]         super.addAll(values,
> > > > > >>> result.removedContributor_);
> > > > > >>> >>> >     [javac]              ^
> > > > > >>> >>> >     [javac] 1 error
> > > > > >>> >>> >     [javac] 40 warnings
> > > > > >>> >>> >
> > > > > >>> >>> > BUILD FAILED
> > > > > >>> >>> > C:\TomsProjects\wave\build.xml:100:
The following error
> > > > occurred
> > > > > >>> while
> > > > > >>> >>> > executing
> > > > > >>> >>> >  this line:
> > > > > >>> >>> > C:\TomsProjects\wave\build-macros.xml:68:
Compile failed;
> > see
> > > > the
> > > > > >>> >>> compiler
> > > > > >>> >>> > error
> > > > > >>> >>> >  output for details.
> > > > > >>> >>> >
> > > > > >>> >>> > Total time: 12 seconds
> > > > > >>> >>> >
> > > > > >>> >>> >
> > > > > >>> >>> >
> > > > > >>> >>> >
> > > > > >>> >>> > ~~~
> > > > > >>> >>> > Thomas & Bertines online review
show:
> > > > > >>> >>> > http://randomreviewshow.com/index.html
> > > > > >>> >>> > Try it! You might even feel ambivalent
about it :)
> > > > > >>> >>> >
> > > > > >>> >>> >
> > > > > >>> >>> > On 2 December 2013 21:03, Yuri Z <vega113@gmail.com>
> > wrote:
> > > > > >>> >>> >
> > > > > >>> >>> > > I think the most up to date installation
guide is the
> > > README
> > > > > >>> file -
> > > > > >>> >>> > > https://github.com/apache/wave/blob/trunk/README
> > > > > >>> >>> > >
> > > > > >>> >>> > >
> > > > > >>> >>> > >
> > > > > >>> >>> > > On Mon, Dec 2, 2013 at 5:53 PM,
Thomas Wrobel <
> > > > > >>> darkflame@gmail.com>
> > > > > >>> >>> > wrote:
> > > > > >>> >>> > >
> > > > > >>> >>> > > > Stuck #3:
> > > > > >>> >>> > > > "ANT"
> > > > > >>> >>> > > > Buildfile: C:\TomsProjects\wave\build.xml
> > > > > >>> >>> > > >
> > > > > >>> >>> > > > check-test-dependencies:
> > > > > >>> >>> > > >
> > > > > >>> >>> > > > BUILD FAILED
> > > > > >>> >>> > > > C:\TomsProjects\wave\build.xml:259:
You need to
> execute
> > > the
> > > > > >>> >>> > > get-third-party
> > > > > >>> >>> > > > targ
> > > > > >>> >>> > > > et to download dependencies
required for tests
> > > compilation,
> > > > > >>> i.e.
> > > > > >>> >>> ant
> > > > > >>> >>> > > > get-third-p
> > > > > >>> >>> > > > arty. third_party/test/emma/emma_ant.jar
> > > > > >>> >>> > > >
> > > > > >>> >>> > > >
> > > > > >>> >>> > > >
> > > > > >>> >>> > > >
> > > > > >>> >>> > > > ~~~
> > > > > >>> >>> > > > Thomas & Bertines online
review show:
> > > > > >>> >>> > > > http://randomreviewshow.com/index.html
> > > > > >>> >>> > > > Try it! You might even feel
ambivalent about it :)
> > > > > >>> >>> > > >
> > > > > >>> >>> > > >
> > > > > >>> >>> > > > On 2 December 2013 15:13,
Thomas Wrobel <
> > > > darkflame@gmail.com
> > > > > >
> > > > > >>> >>> wrote:
> > > > > >>> >>> > > >
> > > > > >>> >>> > > > >  Note #2:
> > > > > >>> >>> > > > > Should be made clear
your need JDK installed, with
> a
> > > link
> > > > > to
> > > > > >>> the
> > > > > >>> >>> Java
> > > > > >>> >>> > > > > site. (not just JRE).
> > > > > >>> >>> > > > >
> > > > > >>> >>> > > > > Note #3:
> > > > > >>> >>> > > > > Should be clarified
that the ANT command doesn't
> work
> > > in
> > > > XP
> > > > > >>> just
> > > > > >>> >>> by
> > > > > >>> >>> > > > adding
> > > > > >>> >>> > > > > its path to a "ANT"
system variable.
> > > > > >>> >>> > > > > The path to ANT has
to be added to the already
> > existing
> > > > > PATH
> > > > > >>> >>> system
> > > > > >>> >>> > > > > variable. (and it should
be just to the "bin"
> > > directory,
> > > > > the
> > > > > >>> >>> \ant at
> > > > > >>> >>> > > the
> > > > > >>> >>> > > > > end shouldn't be there.
> > > > > >>> >>> > > > > People can use "echo
%PATH%" to check its added ok.
> > > > > >>> >>> > > > >
> > > > > >>> >>> > > > > (I will start expanding/changing
the guide as soon
> > as I
> > > > > have
> > > > > >>> >>> write
> > > > > >>> >>> > > > > permission, although
I will post changes first here
> > as
> > > > > well,
> > > > > >>> in
> > > > > >>> >>> case
> > > > > >>> >>> > I
> > > > > >>> >>> > > > have
> > > > > >>> >>> > > > > got something wrong
or its specific to XP and Win7
> is
> > > > > treated
> > > > > >>> >>> > > > differently)
> > > > > >>> >>> > > > >
> > > > > >>> >>> > > > >
> > > > > >>> >>> > > > >
> > > > > >>> >>> > > > >
> > > > > >>> >>> > > > > ~~~
> > > > > >>> >>> > > > > Thomas & Bertines
online review show:
> > > > > >>> >>> > > > > http://randomreviewshow.com/index.html
> > > > > >>> >>> > > > > Try it! You might even
feel ambivalent about it :)
> > > > > >>> >>> > > > >
> > > > > >>> >>> > > > >
> > > > > >>> >>> > > > > On 2 December 2013
02:36, Ali Lown <ali@lown.me.uk
> >
> > > > wrote:
> > > > > >>> >>> > > > >
> > > > > >>> >>> > > > >> > For the ant,
do I just go for the route (that is
> > the
> > > > > >>> "wave"
> > > > > >>> >>> > > directory
> > > > > >>> >>> > > > >> > rather then
the  "wave-protocol" one that
> doesn't
> > > > exist
> > > > > >>> now?
> > > > > >>> >>> > > > >>
> > > > > >>> >>> > > > >> Yes.
> > > > > >>> >>> > > > >>
> > > > > >>> >>> > > > >
> > > > > >>> >>> > > > >
> > > > > >>> >>> > > >
> > > > > >>> >>> > >
> > > > > >>> >>> >
> > > > > >>> >>>
> > > > > >>> >>
> > > > > >>> >>
> > > > > >>> >
> > > > > >>>
> > > > > >>
> > > > > >>
> > > > > >
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message