incubator-wave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Wrobel <darkfl...@gmail.com>
Subject Re: Setting up Wave for client development (my experience setting up on WindowsXP)
Date Mon, 02 Dec 2013 21:10:24 GMT
ah...no...a fresh download of jdk7
I'll downgrade.

~~~
Thomas & Bertines online review show:
http://randomreviewshow.com/index.html
Try it! You might even feel ambivalent about it :)


On 2 December 2013 21:39, Ali Lown <ali@lown.me.uk> wrote:

> Are you definitely using jdk6?
> On 2 Dec 2013 20:25, "Thomas Wrobel" <darkflame@gmail.com> wrote:
>
> > Thanks - I'll use that one as a reference now, but I'll aim to
> edit/update
> > the other one (as that seems a bit more "friendly" for someone getting
> > started).
> > ---
> > Notes #4:
> > ant get-third-party is needed before running ant.
> > --- Stuck #4:
> > Build error;
> > C:\TomsProjects\wave>ant Buildfile: C:\TomsProjects\wave\build.xml
> > check-test-dependencies: init-logging: [mkdir] Created dir:
> > C:\TomsProjects\wave\build\logs [echo] Logging to
> > C:\TomsProjects\wave/build/logs/build_2013-11-29_17-48-35 .log init:
> > [mkdir] Created dir: C:\TomsProjects\wave\build\proto [mkdir] Created
> dir:
> > C:\TomsProjects\wave\build\messages [mkdir] Created dir:
> > C:\TomsProjects\wave\build\src [mkdir] Created dir:
> > C:\TomsProjects\wave\build\test [mkdir] Created dir:
> > C:\TomsProjects\wave\build\coverage [mkdir] Created dir:
> > C:\TomsProjects\wave\dist [mkdir] Created dir:
> > C:\TomsProjects\wave\build\staging [mkdir] Created dir:
> > C:\TomsProjects\wave\build\dep [mkdir] Created dir:
> > C:\TomsProjects\wave\test_out compile-proto-dep: compile-proto: [javac]
> > Compiling 12 source files to C:\TomsProjects\wave\build\proto [javac]
> > C:\TomsProjects\wave\proto_src\org\waveprotocol\box\attachment\Attac
> > hmentProto.java:344: warning: [static] static method should be qualified
> by
> > type name, Builder, instead of by an expression [javac]
> > super.addAll(values, result.attachment_); [javac] ^ [javac] error:
> warnings
> > found and -Werror specified [javac]
> > C:\TomsProjects\wave\proto_src\org\waveprotocol\box\common\comms\Wav
> > eClientRpc.java:990: warning: [static] static method should be qualified
> by
> > type name, Builder, instead of by an expression [javac]
> > super.addAll(values, result.waveletIdPrefix_); [javac] ^
> > ...(and a lot of similiar warnings ending in a ...
> >
> >     [javac]         super.addAll(values, result.removedContributor_);
> >     [javac]              ^
> >     [javac] 1 error
> >     [javac] 40 warnings
> >
> > BUILD FAILED
> > C:\TomsProjects\wave\build.xml:100: The following error occurred while
> > executing
> >  this line:
> > C:\TomsProjects\wave\build-macros.xml:68: Compile failed; see the
> compiler
> > error
> >  output for details.
> >
> > Total time: 12 seconds
> >
> >
> >
> >
> > ~~~
> > Thomas & Bertines online review show:
> > http://randomreviewshow.com/index.html
> > Try it! You might even feel ambivalent about it :)
> >
> >
> > On 2 December 2013 21:03, Yuri Z <vega113@gmail.com> wrote:
> >
> > > I think the most up to date installation guide is the README file -
> > > https://github.com/apache/wave/blob/trunk/README
> > >
> > >
> > >
> > > On Mon, Dec 2, 2013 at 5:53 PM, Thomas Wrobel <darkflame@gmail.com>
> > wrote:
> > >
> > > > Stuck #3:
> > > > "ANT"
> > > > Buildfile: C:\TomsProjects\wave\build.xml
> > > >
> > > > check-test-dependencies:
> > > >
> > > > BUILD FAILED
> > > > C:\TomsProjects\wave\build.xml:259: You need to execute the
> > > get-third-party
> > > > targ
> > > > et to download dependencies required for tests compilation, i.e. ant
> > > > get-third-p
> > > > arty. third_party/test/emma/emma_ant.jar
> > > >
> > > >
> > > >
> > > >
> > > > ~~~
> > > > Thomas & Bertines online review show:
> > > > http://randomreviewshow.com/index.html
> > > > Try it! You might even feel ambivalent about it :)
> > > >
> > > >
> > > > On 2 December 2013 15:13, Thomas Wrobel <darkflame@gmail.com> wrote:
> > > >
> > > > >  Note #2:
> > > > > Should be made clear your need JDK installed, with a link to the
> Java
> > > > > site. (not just JRE).
> > > > >
> > > > > Note #3:
> > > > > Should be clarified that the ANT command doesn't work in XP just
by
> > > > adding
> > > > > its path to a "ANT" system variable.
> > > > > The path to ANT has to be added to the already existing PATH system
> > > > > variable. (and it should be just to the "bin" directory, the \ant
> at
> > > the
> > > > > end shouldn't be there.
> > > > > People can use "echo %PATH%" to check its added ok.
> > > > >
> > > > > (I will start expanding/changing the guide as soon as I have write
> > > > > permission, although I will post changes first here as well, in
> case
> > I
> > > > have
> > > > > got something wrong or its specific to XP and Win7 is treated
> > > > differently)
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > ~~~
> > > > > Thomas & Bertines online review show:
> > > > > http://randomreviewshow.com/index.html
> > > > > Try it! You might even feel ambivalent about it :)
> > > > >
> > > > >
> > > > > On 2 December 2013 02:36, Ali Lown <ali@lown.me.uk> wrote:
> > > > >
> > > > >> > For the ant, do I just go for the route (that is the "wave"
> > > directory
> > > > >> > rather then the  "wave-protocol" one that doesn't exist
now?
> > > > >>
> > > > >> Yes.
> > > > >>
> > > > >
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message