incubator-wave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ali Lown" <...@lown.me.uk>
Subject Re: Review Request: Fix welcome_wave_id warning
Date Thu, 06 Jun 2013 19:42:54 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/11676/#review21537
-----------------------------------------------------------

Ship it!


LGTM.

- Ali Lown


On June 6, 2013, 4:26 p.m., Bruno Gonzalez wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/11676/
> -----------------------------------------------------------
> 
> (Updated June 6, 2013, 4:26 p.m.)
> 
> 
> Review request for wave.
> 
> 
> Description
> -------
> 
> The configuration file has an empty default welcome_wave_id.
> The source code, however, uses "UNDEFINED" to check if the welcome wave functionality
should be ignored.
> 
> This patch uses an empty string for all checks and default values.
> 
> 
> Diffs
> -----
> 
>   src/org/waveprotocol/box/server/CoreSettings.java 31cb4ea 
>   src/org/waveprotocol/box/server/robots/agent/welcome/WelcomeRobot.java 07cb78d 
> 
> Diff: https://reviews.apache.org/r/11676/diff/
> 
> 
> Testing
> -------
> 
> Remove any welcome_wave_id from your server.config file, start wiab server, and check
this message does NOT appear on the logs anymore: "Problem parsing welcome wave id: "
> 
> 
> Thanks,
> 
> Bruno Gonzalez
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message