incubator-wave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vicente J. Ruiz Jurado" <v...@ourproject.org>
Subject Re: Review Request: Webclient should use socketio when websocket does not connect
Date Wed, 17 Oct 2012 00:40:18 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/7602/
-----------------------------------------------------------

(Updated Oct. 17, 2012, 12:40 a.m.)


Review request for wave, Michael MacFadden, Yuri Zelikov, and Ali Lown.


Changes
-------

New patch following Ali comments.


Description
-------

This patch fix WAVE-376, that is, detect that websocket it's not working and try to use socket.io
instead.

This patch depends on https://reviews.apache.org/r/7600/ to work properly.


This addresses bug WAVE-376.
    https://issues.apache.org/jira/browse/WAVE-376


Diffs (updated)
-----

  src/org/waveprotocol/box/webclient/client/WaveWebSocketClient.java 5645f5e 
  src/org/waveprotocol/box/webclient/client/WebClient.java 863ae6c 

Diff: https://reviews.apache.org/r/7602/diff/


Testing
-------

How to test this:
- Configure your local WIAB under a http_proxy
- or:
1) Configure your server websocket with a different name for websocket address, for instance
ws.localhost
2) configure it in the /etc/hosts
127.0.0.1 ws.localhost
3) run the server
4) test that all works ok using websocket
5) remove the entry from /etc/hosts
6) refresh your browser and check that websocket is not working and the client use socketio
instead.


Thanks,

Vicente J. Ruiz Jurado


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message