incubator-wave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ali Lown <a.lo...@gmail.com>
Subject Re: Failure to Build Wave
Date Sun, 09 Sep 2012 09:24:40 GMT
Hi Xiaofeng,

We try to ensure that the trunk is always buildable (and so most of the
time it is).

Looking at your stacktrace the critical line seems to be " Caused by:
java.security.cert.CertificateExpiredException: NotAfter:
Fri Sep 09 11:28:30 CST 2011".

Is the date/time on your machine correct? Are you using the latest trunk
from the wave repository, because the error says the certificate expired in
September last year?

Ali.
On 9 Sep 2012 10:08, "郭晓峰" <lamuguo@gmail.com> wrote:

> Hi there,
>
> Just try to build it, but looks failed.
>
>     [junit] Running org.waveprotocol.wave.crypto.CertpathTest
>     [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0.038 sec
>
> Details as below:
> Name    Status  Type    Time(s)
> testValidator_canGrokCriticalExtension  Error   Certificate validation
> failure
>
> org.waveprotocol.wave.crypto.SignatureException: Certificate validation
> failure
> at
> org.waveprotocol.wave.crypto.CachedCertPathValidator.validateNoCache(CachedCertPathValidator.java:103)
> at
> org.waveprotocol.wave.crypto.CachedCertPathValidator.validate(CachedCertPathValidator.java:65)
> at
> org.waveprotocol.wave.crypto.CertpathTest.testValidator_canGrokCriticalExtension(CertpathTest.java:96)
> Caused by: java.security.cert.CertPathValidatorException: timestamp check
> failed
> at
> sun.security.provider.certpath.PKIXMasterCertPathValidator.validate(PKIXMasterCertPathValidator.java:153)
> at
> sun.security.provider.certpath.PKIXCertPathValidator.doValidate(PKIXCertPathValidator.java:325)
> at
> sun.security.provider.certpath.PKIXCertPathValidator.engineValidate(PKIXCertPathValidator.java:187)
> at
> java.security.cert.CertPathValidator.validate(CertPathValidator.java:267)
> at
> org.waveprotocol.wave.crypto.CachedCertPathValidator.validateNoCache(CachedCertPathValidator.java:101)
> Caused by: java.security.cert.CertificateExpiredException: NotAfter:
> Fri Sep 09 11:28:30 CST 2011
> at
> sun.security.x509.CertificateValidity.valid(CertificateValidity.java:273)
> at sun.security.x509.X509CertImpl.checkValidity(X509CertImpl.java:587)
> at
> sun.security.provider.certpath.BasicChecker.verifyTimestamp(BasicChecker.java:178)
> at sun.security.provider.certpath.BasicChecker.check(BasicChecker.java:130)
> at
> sun.security.provider.certpath.PKIXMasterCertPathValidator.validate(PKIXMasterCertPathValidator.java:131)
> 0.037
> Properties »
>
> Is there anyone keeping the repository correct? Do I need to take a
> look at it myself? Thanks!
>
> Best Regards,
> Xiaofeng
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message