incubator-wave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yuri Z <vega...@gmail.com>
Subject Re: Is federation working with current head?
Date Fri, 10 Aug 2012 08:24:06 GMT
No, the certificates for waveinabox.net got expired and I never cared to
refresh them.  Also - there was no other wave servers available to test
federation...
>From the log it looks like the federation is working but the request for
delta history returns null. Can you maybe add some logs so show what are
the values of startVersion and endVersion?

On Thu, Aug 9, 2012 at 4:44 PM, Ali Lown <ali@lown.me.uk> wrote:

> I am trying to setup 2 local servers for testing federation (and for
> ensuring I don't break it with any code changes), but I can't seem to
> get it setup.
>
> If you want to check if my DNS SRV records are correct, you can check
> for the following 2 domains:
> wavefed1.testing.eezysys.co.uk and wavefed2.testing.eezysys.co.uk
> though since I get:
> 09-Aug-2012 05:17:09 org.waveprotocol.wave.federation.xmpp.RemoteDisco
> requestDiscoInfo
> INFO: Sending disco info request for: wave.wavefed1.testing.eezysys.co.uk
> 09-Aug-2012 05:17:09 org.waveprotocol.wave.federation.xmpp.RemoteDisco
> finish
> INFO: Discovered remote JID: wave.wavefed1.testing.eezysys.co.uk for
> wavefed1.testing.eezysys.co.uk
> in the logfile, it sounds like the DNS settings are correct.
>
> At the moment when I create a new wave with the a user from the other
> server in it, the prosody servers show data being sent, but the wave
> logs fill up with the following error:
> Exception in thread "pool-10-thread-42" java.lang.NullPointerException
>         at
> org.waveprotocol.box.server.waveserver.WaveServerImpl.requestHistory(WaveServerImpl.java:229)
>         at sun.reflect.GeneratedMethodAccessor26.invoke(Unknown Source)
>         at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>         at java.lang.reflect.Method.invoke(Method.java:616)
>         at
> com.google.inject.internal.DelegatingInvocationHandler.invoke(DelegatingInvocationHandler.java:37)
>         at $Proxy17.requestHistory(Unknown Source)
>         at
> org.waveprotocol.wave.federation.xmpp.XmppFederationHost.processHistoryRequest(XmppFederationHost.java:227)
>         at
> org.waveprotocol.wave.federation.xmpp.XmppManager.processIqGetSet(XmppManager.java:317)
>         at
> org.waveprotocol.wave.federation.xmpp.XmppManager.receivePacket(XmppManager.java:147)
>         at
> org.waveprotocol.wave.federation.xmpp.ComponentPacketTransport.processPacket(ComponentPacketTransport.java:130)
>         at
> org.jivesoftware.whack.ExternalComponent$1.run(ExternalComponent.java:333)
>         at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
>         at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
>         at java.lang.Thread.run(Thread.java:636)
>
> Is anyone using federation at the moment with the current head?
> Because either a) it is currently broken, if so I will take a look
> into it or b) my setup is incorrect and wave's error message is
> unhelpful.
>
> Thanks.
> Ali
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message