incubator-wave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ali Lown <...@lown.me.uk>
Subject Re: Review Request: Do not show time in blips when it's 1970
Date Fri, 03 Aug 2012 12:48:28 GMT
I don't like the feel of this 'patch', since it doesn't address the actual
issue...

Could we not either:
A) extend the protocol, to send this information (in some backwards
compatible way)
B) have the client display the time the delta was received from the server
in this situation (which would provide a close approximation to the actual
time that would be sent had it loaded it as a snapshot instead)

Ali
On 3 Aug 2012 14:04, "Vicente J. Ruiz Jurado" <vjrj@ourproject.org> wrote:

>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/6339/
> -----------------------------------------------------------
>
> Review request for wave, Michael MacFadden, Yuri Zelikov, and Ali Lown.
>
>
> Description
> -------
>
> This patch does not set the time in blips when the date is 1970. From
> WAVE-181:
>
> "The cause is that the existing c/s protocol has no timestamp for document
> updates (but does for snapshots)."
>
>
> This addresses bug WAVE-181.
>     https://issues.apache.org/jira/browse/WAVE-181
>
>
> Diffs
> -----
>
>
> src/org/waveprotocol/wave/client/wavepanel/render/UndercurrentShallowBlipRenderer.java
> 1521736
>
> src/org/waveprotocol/wave/client/wavepanel/view/dom/full/BlipMetaViewBuilder.java
> 45f074b
>
> Diff: https://reviews.apache.org/r/6339/diff/
>
>
> Testing
> -------
>
> Test ant waveharness-hosted
>
>
> Thanks,
>
> Vicente J. Ruiz Jurado
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message