incubator-wave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael MacFadden <michael.macfad...@gmail.com>
Subject Re: Maven built WIAB running!
Date Wed, 30 May 2012 16:20:07 GMT
After installing with brew, it still is not completely working.  It is generating some sources,
but not all of them...



If you have gtalk, you can get me on that using my gmail address.

On May 30, 2012, at 9:10 AM, Paulo Pires wrote:

> Michael,
> 
> I hope you don't think that I'm underestimating your abilities! That's 
> in no way whatsoever what I meant.
> 
> The thing is that current mainstream WIAB doesn't compile the proto 
> files but instead had it compiled once and persisted the resulting Java 
> classes in SVN, am I right? And that's why I pointed you the poor 
> documentation provided, as I've changed this behavior and couldn't be 
> sure if you've overlooked it or not.
> 
> Anyway, I'm eager to get your changes!
> 
> Good luck,
> PP
> 
> On Wed May 30 16:55:11 2012, Michael MacFadden wrote:
>> Paulo,
>> 
>> For some context.  I am one of the Apache Wave project committers and PMC members.
 I have been working on wave for several years now (although I have been coding a bit less).
 So, I do have protoc installed and can currently build wiab.  I suspect there is just some
differences in the default settings.  For example, the location of your protoc install is
not the same as mine.  There could be some other issues like that.  I will chase them down.
>> 
>> 
>> On May 30, 2012, at 8:47 AM, Paulo Pires wrote:
>> 
>>> Have you got protobuf-compiler installed? See README.md and
>>> build-proto.properties for instructions.
>>> 
>>> Anyway, I've tested this with a clean Lion (no Maven cache and a new
>>> clone) and it worked. Also, I had the same result with a clean Linux
>>> Mint 13 installed.
>>> 
>>> On Wed May 30 16:44:29 2012, Michael MacFadden wrote:
>>>> OSX.  I almost have it building right now it is not generating the protobuf
messages. (what used to go into gen/messages in the old project).  So for example:
>>>> 
>>>> import org.waveprotocol.box.common.comms.proto.DocumentSnapshotProtoImpl;
>>>> 
>>>> Is not being generated.  I think this is the last step.
>>>> 
>>>> 
>>>> On May 30, 2012, at 8:32 AM, Paulo Pires wrote:
>>>> 
>>>>> Which OS are you running?
>>>>> 
>>>>> PP
>>>>> 
>>>>> On Wed May 30 15:59:31 2012, Michael MacFadden wrote:
>>>>>> Paulo,
>>>>>> 
>>>>>> This worked but only after I change the line in the pom where the
local repo is defined.  I changed it from:
>>>>>> 
>>>>>> <url>file:///${basedir}/../repo/</url>
>>>>>> 
>>>>>> to
>>>>>> 
>>>>>> <url>file://${basedir}/../repo/</url>
>>>>>> 
>>>>>> On May 30, 2012, at 5:48 AM, Paulo Pires wrote:
>>>>>> 
>>>>>>> My bad! It's now fixed in
>>>>>>> https://github.com/pires/wave/commit/8f016c455345a1210ad195f01414c02e2227273a
>>>>>>> 
>>>>>>> Please, confirm this change fixes the issue you're facing.
>>>>>>> 
>>>>>>> PP
>>>>>>> 
>>>>>>> On 30/05/12 05:13, Michael MacFadden wrote:
>>>>>>>> Paulo,
>>>>>>>> 
>>>>>>>> Did you perhaps add several jars to you local maven repository?
 When I try to compile the project, I get several dependencies that done resolve.
>>>>>>>> 
>>>>>>>> Missing artifact net.oauth:consumer:jar:20100601
>>>>>>>> Missing artifact net.oauth:provider:jar:20100601
>>>>>>>> ...
>>>>>>>> Missing artifact com.glines.socketio:socketio-core:jar:0.1-SNAPSHOT
>>>>>>>> 
>>>>>>>> And some others.
>>>>>>>> 
>>>>>>>> ~Michael
>>>>>>>> 
>>>>>>>> 
>>>>>>>> On May 29, 2012, at 5:18 PM, Paulo Pires wrote:
>>>>>>>> 
>>>>>>>>> That's great, Michael!
>>>>>>>>> 
>>>>>>>>> Since the project is now split in modules, I believe
that we should
>>>>>>>>> follow section 15 of
>>>>>>>>> http://mojo.codehaus.org/gwt-maven-plugin/pdf/gwt-maven-plugin.pdf
>>>>>>>>> 
>>>>>>>>> Eventually, we can even extract 'webclient' stuff from
'box' module to
>>>>>>>>> a new one.
>>>>>>>>> 
>>>>>>>>> PP
>>>>>>>>> 
>>>>>>>>> On Wed May 30 00:57:29 2012, Michael MacFadden wrote:
>>>>>>>>>> I am working on the gwt maven plugin now
>>>>>>>>>> 
>>>>>>>>>> -Michael.
>>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>>>> On May 29, 2012, at 4:34 PM, Paulo Pires <pjpires@ubiwhere.com>
wrote:
>>>>>>>>>> 
>>>>>>>>>>> I only need to get GWT compiled to JS and then
I think I'll be able to
>>>>>>>>>>> use it fully.
>>>>>>>>>>> 
>>>>>>>>>>> On Tue May 29 23:18:47 2012, Paulo Pires wrote:
>>>>>>>>>>>> Hi all,
>>>>>>>>>>>> 
>>>>>>>>>>>> I've got to a state where I can run WIAB
and register/log a user. Anyone
>>>>>>>>>>>> willing to give it a try and report issues
at
>>>>>>>>>>>> https://github.com/pires/wave/issues/5 ?
>>>>>>>>>>>> 
>>>>>>>>>>>> When we reach a WIAB fully running instance
with this fork, I'll get
>>>>>>>>>>>> back to a proper upstream fix for WAVE-294.
>>>>>>>>>>>> 
>>>>>>>>>>>> Cheers,
>>>>>>>>>>>> 
>>>>>>>>>>> --
>>>>>>>>>>> Paulo Pires
>>>>>>>>> --
>>>>>>>>> Paulo Pires
>>>>>>>> 
>>>>>>> 
>>>>>>> --
>>>>>>> Paulo Pires
>>>>>>> 
>>>>>> 
>>>>>> 
>>>>> 
>>>>> --
>>>>> Paulo Pires
>>>> 
>>>> 
>>> 
>>> --
>>> Paulo Pires
>> 
> 
> --
> Paulo Pires


Mime
View raw message