incubator-wave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Hearnden <hearn...@google.com>
Subject Re: Compile error
Date Mon, 21 Mar 2011 23:13:38 GMT
Hi Giacomo,

Can you please apply the following patch (it's a 1-line change) and see if
it fixes the issue? If so, I'll prepare a patch for it.  I'd test it myself,
but I'm unable to reproduce the original error (which but I'm fairly sure is
from using an older version of Java 6).  If it doesn't work, let's create an
issue and move discussion over there.

-Dave

On Tue, Mar 22, 2011 at 8:36 AM, James Purser <jamesrpurser@gmail.com>wrote:

> Yeah, this is a known issue that seems to be affecting some, though not all
> of us.
>
> What version of Java are you using?
>
> On Tue, Mar 22, 2011 at 4:14 AM, Giacomo Piva <piva@innovativa.it> wrote:
>
> > Hi all,
> > I'm getting start with google wave protocol and I'm getting this error:
> >
> >    [javac] required: org.waveprotocol.wave.client.scroll.ScrollPanel<?
> > super java.lang.Object>
> >    [javac] found: org.waveprotocol.wave.client.scroll.ProxyScrollPanel
> >    [javac]     return SmartScroller.create(scroller);
> >    [javac]                                ^
> >    [javac] Note: Some input files use or override a deprecated API.
> >    [javac] Note: Recompile with -Xlint:deprecation for details.
> >    [javac] 1 error
> >
> > I'm trying to compile it on Ubuntu server 9.04
> > Some suggestion?
> >
> > Thanks
> >
> > -
> > G.
>
>
>
>
> --
> James Purser
> Collaborynth
> http://collaborynth.com.au
> Mob: +61 406 576 553
> Wave: james@collaborynth.com.au
>

Mime
View raw message