incubator-tashi-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kushal Dalmia" <kdal...@andrew.cmu.edu>
Subject Tashi Networking Issue
Date Sat, 10 Dec 2011 01:33:33 GMT
Hi,

I am trying to setup Tashi in a cluster environment. My configuration is
as follows:

                     Host B (Node Manager)
Host A           /
(Cluster Manager)\
                     Host C (Node Manager)

I am using the Qemu backend and using Virtual Bridges for VM connectivity.
In my current setup, I am creating Virtual Bridges on Hosts A, B and C.
All three virtual bridges are part of the same subnet (192.168.2.*)

When I create a new VM, it gets successfully created on one of B/C. I can
easily ping/ssh into the VM from whichever host it is created on. However,
my application requires it to be reachable/sshable from host A as well.
Host A can ping the virtual bridges on B and C (and vice-versa as well).
Also, the VM can ping the virtual bridge on the host but not other nodes. 
Is there anything I am missing in my setup? The outputs for "ifconfig" and
"ip route show" for all three hosts are as below.

Thanks,
Kushal Dalmia
Carnegie Mellon University


_Host A_ (Cluster Manager)
20:23:13 # ifconfig
em1       Link encap:Ethernet  HWaddr 84:2B:2B:01:C8:BE
          inet addr:128.2.220.27  Bcast:128.2.221.255  Mask:255.255.254.0
....
em2       Link encap:Ethernet  HWaddr 84:2B:2B:01:C8:BF
          inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
....
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
....
mybridge  Link encap:Ethernet  HWaddr 84:2B:2B:01:C8:BF
          inet addr:192.168.2.10  Bcast:192.168.2.255  Mask:255.255.255.0
....

20:23:19 # ip route show
192.168.2.30 dev em1  scope link
192.168.2.20 dev em1  scope link
192.168.2.0/24 dev em1  scope link
128.2.220.0/23 dev em1  proto kernel  scope link  src 128.2.220.27
default via 128.2.220.1 dev em1

20:25:01 # brctl show
bridge name	bridge id		STP enabled	interfaces
mybridge		8000.842b2b01c8bf	no		em2

_Host B_ and _Host C_ (Both NMs have the same setup except bridge IP Addrs):
20:25:38 # ifconfig
em1       Link encap:Ethernet  HWaddr 84:2B:2B:01:CC:1C
          inet addr:128.2.220.30  Bcast:128.2.221.255  Mask:255.255.254.0
....
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
....
mybridge  Link encap:Ethernet  HWaddr 84:2B:2B:01:CC:1D
          inet addr:192.168.2.20  Bcast:192.168.2.255  Mask:255.255.255.0
....
tashi2.0  Link encap:Ethernet  HWaddr 86:68:BD:53:E6:1F
          inet6 addr: fe80::8468:bdff:fe53:e61f/64 Scope:Link
....
tashi3.0  Link encap:Ethernet  HWaddr D2:4C:25:28:0A:98
          inet6 addr: fe80::d04c:25ff:fe28:a98/64 Scope:Link
....

20:29:42 # ip route show
192.168.2.10 dev em1  scope link
192.168.2.1 dev em1  scope link
192.168.2.0/24 dev mybridge  proto kernel  scope link  src 192.168.2.20
128.2.220.0/23 dev em1  proto kernel  scope link  src 128.2.220.30
169.254.0.0/16 dev em1  scope link  metric 1002
default via 128.2.220.1 dev em1  proto static

20:29:50 # brctl show
bridge name	bridge id		STP enabled	interfaces
mybridge		8000.842b2b01cc1d	no		em2
							tashi2.0
							tashi3.0



Mime
View raw message