incubator-tashi-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hari narayanan <hari.zla...@gmail.com>
Subject Re: Problem with starting node manager
Date Tue, 03 May 2011 05:10:07 GMT
Hi,

We are trying to make it work with Qemu again ... We took the Qemu command
from the NodeManager and ran it on a seperate terminal as a root. In that
case, we get the error "could not launch Network script " .. however, if we
dont run the command as root, we get the error "no network emulation" .. Any
thoughts?

Thanks,
Hari

On Thu, Apr 28, 2011 at 7:21 PM, hari narayanan <hari.zlatan@gmail.com>wrote:

> it gives hostid->none error when i issue the
>
> "./bin/tashi-client vmmspecificcall --instance foobar --arg startvnc" ...
> and in the primitive.py terminal , "i see FAILED to schedule or activate vm
> ... key error 2 "
>
> This is the same error that i was getting when using qemu too
>
>
>
> On Thu, Apr 28, 2011 at 7:12 PM, Richard Gass <richardgass@gmail.com>wrote:
>
>> I am not that familiar with Xen.  Maybe Michael S can answer from
>> here.  Where do you see hostid->none error?  I you could just copy and
>> paste your messages to the screen maybe I can help.  It has been
>> awhile since I have encountered these error so I might not remember
>> exactly what to do.  However, if you show me exactly what is printed
>> to the screen, it may job my memory.
>>
>> Richard
>>
>>
>> On Fri, Apr 29, 2011 at 2:06 AM, hari narayanan <hari.zlatan@gmail.com>
>> wrote:
>> > Sorry for the trouble ... We created the Vm based on the hostname found
>> in
>> > /etc/hosts. After creating the vm, we still get hostid->none error...
>> > gethosts at the CM lists our laptop, but primitive.py says "Failed to
>> > schedule or activate vm" ... vncviewer works for domU images in xen...
>> so,
>> > if we add the host (laptop) , then how can we vncview into it
>> considering
>> > its dom0?
>> >
>> > On Thu, Apr 28, 2011 at 5:14 PM, Richard Gass <richardgass@gmail.com>
>> wrote:
>> >>
>> >> Tashi doesn't use thrift anymore.  We switched to rpyc.  Install that.
>> >>
>> >> If you didn't have ipython installed, when you start the CM or NM, you
>> >> would not have an active prompt, just log messages.  If you restart
>> >> now, you should get an ipython prompt.  Can you show the output of
>> >> data.baseDataObject.hosts now?
>> >>
>> >> Richard
>> >>
>> >>
>> >> On Fri, Apr 29, 2011 at 12:10 AM, hari narayanan <
>> hari.zlatan@gmail.com>
>> >> wrote:
>> >> > No, but we installed it just now ... we dont have thrift installed
>> ....
>> >> > should we get that also ??
>> >> >
>> >> > And we always start CM as u said ....
>> >> >
>> >> >
>> >> >
>> >> > On Thu, Apr 28, 2011 at 4:49 PM, Richard Gass <richardgass@gmail.com
>> >
>> >> > wrote:
>> >> >>
>> >> >> Do you have ipython installed?
>> >> >>
>> >> >> On Thu, Apr 28, 2011 at 11:38 PM, hari narayanan
>> >> >> <hari.zlatan@gmail.com>
>> >> >> wrote:
>> >> >> > We dont get output for data.baseDataObject.hosts in CM ....
but,
>> we
>> >> >> > get
>> >> >> > the
>> >> >> > laptop name in tashiclient. getHosts with state Normal...
>> >> >> >
>> >> >> > On Thu, Apr 28, 2011 at 4:32 PM, Richard Gass <
>> richardgass@gmail.com>
>> >> >> > wrote:
>> >> >> >>
>> >> >> >> Send me the following information.  on the CM
>> >> >> >> "data.baseDataObject.hosts" or from the tashi client "tashi
>> >> >> >> gethosts"
>> >> >> >>
>> >> >> >>
>> >> >> >> On Thu, Apr 28, 2011 at 11:22 PM, hari narayanan
>> >> >> >> <hari.zlatan@gmail.com>
>> >> >> >> wrote:
>> >> >> >> > Hi,
>> >> >> >> >
>> >> >> >> > we are able to start the vm image using xen command...
but, it
>> >> >> >> > doesnt
>> >> >> >> > work
>> >> >> >> > when we try with tashi ... Still get the same error
"no
>> >> >> >> > hostid-none"
>> >> >> >> > ...
>> >> >> >> > We
>> >> >> >> > tried to change the CM and NM config files to make
sure that
>> >> >> >> > hostid
>> >> >> >> > value is
>> >> >> >> > equal to our actual laptop's hostname "akshay" ...
and also ,we
>> >> >> >> > are
>> >> >> >> > able
>> >> >> >> > to
>> >> >> >> > ping the address and hostname of the laptop ... what
could be
>> the
>> >> >> >> > prob?
>> >> >> >> >
>> >> >> >> > On Tue, Apr 26, 2011 at 10:16 PM, Akshay Sheth
>> >> >> >> > <aks.sheth88@gmail.com>
>> >> >> >> > wrote:
>> >> >> >> >>
>> >> >> >> >> Hey Micheal,
>> >> >> >> >>
>> >> >> >> >> I was planning to use Sqlite3 but when I write
the insert
>> queries
>> >> >> >> >> that
>> >> >> >> >> the
>> >> >> >> >> tables hosts and networks dont exist. How do
I fix this? Also
>> >> >> >> >> when I
>> >> >> >> >> put
>> >> >> >> >> data.baseDataObject.getHosts on CM I dont get
any output. Also
>> >> >> >> >> eventually I
>> >> >> >> >> get no hostId for the VM. What could be wrong?
>> >> >> >> >>
>> >> >> >> >> Thanks
>> >> >> >> >> Akshay
>> >> >> >> >>
>> >> >> >> >> On Tue, Apr 26, 2011 at 9:55 PM, hari narayanan
>> >> >> >> >> <hari.zlatan@gmail.com>
>> >> >> >> >> wrote:
>> >> >> >> >>>
>> >> >> >> >>> Hi,
>> >> >> >> >>>
>> >> >> >> >>> we have managed to setup internet in xen
and downloaded tashi
>> >> >> >> >>> also
>> >> >> >> >>> ...
>> >> >> >> >>> now, we get a different error  in node manager...
failed to
>> load
>> >> >> >> >>> vminfo
>> >> >> >> >>> /var/tmp/nm.data ... and no vm information
found in
>> >> >> >> >>> /var/tmp/vmcontrolQemu
>> >> >> >> >>> ... When we used vmcspecificcall, we get
the same no hostd
>> none
>> >> >> >> >>> error
>> >> >> >> >>>
>> >> >> >> >>> Thanks,
>> >> >> >> >>> Hari
>> >> >> >> >>>
>> >> >> >> >>> On Tue, Apr 26, 2011 at 6:50 PM, Michael
Stroucken <
>> mxs@cmu.edu>
>> >> >> >> >>> wrote:
>> >> >> >> >>>>
>> >> >> >> >>>> hari narayanan wrote:
>> >> >> >> >>>>>
>> >> >> >> >>>>> Sorry ... We couldnt get it work
. so, we moved to Xen ....
>> >> >> >> >>>>
>> >> >> >> >>>> Hi Hari,
>> >> >> >> >>>>
>> >> >> >> >>>> I used to use Xen until I had too many
problems with booting
>> >> >> >> >>>> kernels
>> >> >> >> >>>> inside the VM image. But with kvm I'm
using the same network
>> >> >> >> >>>> setup
>> >> >> >> >>>> as
>> >> >> >> >>>> I did
>> >> >> >> >>>> with Xen, except for having to add the
qemu-ifup files that
>> I
>> >> >> >> >>>> mentioned
>> >> >> >> >>>> before.
>> >> >> >> >>>>
>> >> >> >> >>>>
>> >> >> >> >>>> Greetings,
>> >> >> >> >>>> Michael.
>> >> >> >> >>>
>> >> >> >> >>
>> >> >> >> >
>> >> >> >> >
>> >> >> >>
>> >> >> >>
>> >> >> >>
>> >> >> >> --
>> >> >> >> Richard Gass
>> >> >> >
>> >> >> >
>> >> >>
>> >> >>
>> >> >>
>> >> >> --
>> >> >> Richard Gass
>> >> >
>> >> >
>> >>
>> >>
>> >>
>> >> --
>> >> Richard Gass
>> >
>> >
>>
>>
>>
>> --
>> Richard Gass
>>
>
>

Mime
View raw message