incubator-syncope-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jordi Clement <jclem...@dds.nl>
Subject Re: Error creating "virtual resource"
Date Wed, 24 Oct 2012 07:35:14 GMT
Hi, 

I've tried this not only with Zimbra, but a few of the other connector bundles too. Some of
those are custom developed, but I'm sure I tested the LDAP and AD connectors as well. Might
be the outdated version of Apache Syncope - I'll try 1.0.2 myself next week. Thanks!

kind regards,

J.

On 24 okt. 2012, at 09:26, Francesco Chicchiriccò <ilgrosso@apache.org> wrote:

> On 23/10/2012 22:02, Jordi Clement wrote:
>> Hi, 
>> 
>> I've tried to simulate "virtual resources" (as discussed the last few days) in Syncope
v0.7.1. This is what I did: 
>> 
>> 1. I created a new connector with name "Virtual.Connector" of type Zimbra (one of
the connectors we've developed ourselves) without any capabilities. 
>> 2. I created and configured a resource with name "Virtual.Resource" using the newly
created connector (Virtual.Connector). I had to add an entry for the accountId to the schema
map: 
>>  - Internal mapping value: SyncopeUserId
>>  - AccountId: checked 
>> 3. I then tried to save but ended up with a Wicket error. The last few lines say:
>> 
>> ERROR: Wicket.Ajax.Call.failure: Error while parsing response: Could not find root
<ajax-response> element
>> INFO: Invoking post-call handler(s)...
>> INFO: Invoking failure handler(s)...
>> 
>> 
>> Any idea what I could have done wrong? Anyone care to try to reproduce?
> 
> Hi Jordi,
> I guess that this failure is mostly related to the connector bundle (Zimbra? interesting!)
you are using or at most to the outdated version (0.7.1).
> 
> I've created a simple project [1] with latest stable version 1.0.2-incubating as proof-of-concept
of the approach already discussed [2]: everything is working as expected, with some limitation,
as reported.
> 
> Regards.
> 
> [1] https://github.com/ilgrosso/syncopeVirtualResource
> [2] http://syncope-user.1051894.n5.nabble.com/Virtual-resources-resources-not-tied-to-an-actual-application-or-system-account-tp5706735p5706743.html
> -- 
> Francesco Chicchiriccò
> 
> ASF Member, Apache Cocoon PMC and Apache Syncope PPMC Member
> http://people.apache.org/~ilgrosso/


Mime
View raw message