incubator-stonehenge-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Dewey <Ben.De...@26ny.com>
Subject RE: WAMP Server PHP/WSF installation
Date Mon, 20 Apr 2009 20:07:47 GMT
I was able to create a WSClient.  In my case the OpenSSL module wasn't found.  I uninstalled
a previous version and used the wamp.zip version that was extracted to the apache/bin folder.
 I also had to correct a Path Environment variable adding the apache/bin folder.

-Ben


-----Original Message-----
From: Ben Dewey [mailto:Ben.Dewey@26ny.com] 
Sent: Monday, April 20, 2009 1:09 PM
To: 'stonehenge-dev@incubator.apache.org'
Subject: WAMP Server PHP/WSF installation

I was able to get the WSF extension loaded in the WAMP server version.  Thanks for all those
who looked into the PHP/IIS issue, I'm still interested in getting that working.

I'm currently having a problem when the WSClient is created, I'm trying to run the echo_client
sample.  I'm getting an error in the constructor that says "Message = ws client create failed".
 Any thoughts?

Here is my wsf_client_log:

[Mon Apr 20 13:01:25 2009] [debug] wsf.c(236) wsf version - 2.0.0
[Mon Apr 20 13:01:25 2009] [debug] wsf.c(237) php version - 5.2.5
[Mon Apr 20 13:01:25 2009] [debug] wsf.c(236) wsf version - 2.0.0
[Mon Apr 20 13:01:25 2009] [debug] wsf.c(237) php version - 5.2.5
[Mon Apr 20 13:02:37 2009] [debug] ..\..\src\core\engine\phase.c(121) axis2_handler_t *request_uri_based_dispatcher
added to the index 0 of the phase Transport
[Mon Apr 20 13:02:37 2009] [debug] ..\..\src\core\engine\phase.c(121) axis2_handler_t *addressing_based_dispatcher
added to the index 1 of the phase Transport
[Mon Apr 20 13:02:37 2009] [debug] ..\..\src\core\engine\phase.c(121) axis2_handler_t *rest_dispatcher
added to the index 0 of the phase Dispatch
[Mon Apr 20 13:02:37 2009] [debug] ..\..\src\core\engine\phase.c(121) axis2_handler_t *soap_message_body_based_dispatcher
added to the index 1 of the phase Dispatch
[Mon Apr 20 13:02:37 2009] [debug] ..\..\src\core\engine\phase.c(121) axis2_handler_t *soap_action_based_dispatcher
added to the index 2 of the phase Dispatch
[Mon Apr 20 13:02:37 2009] [debug] ..\..\src\core\engine\phase.c(121) axis2_handler_t *dispatch_post_conditions_evaluator
added to the index 0 of the phase PostDispatch
[Mon Apr 20 13:02:37 2009] [debug] ..\..\src\core\engine\phase.c(121) axis2_handler_t *context_handler
added to the index 1 of the phase PostDispatch
[Mon Apr 20 13:02:37 2009] [debug] ..\..\src\core\deployment\conf_builder.c(233) No custom
dispatching order found. Continue with the default dispatching order
[Mon Apr 20 13:02:37 2009] [debug] ..\..\src\core\deployment\conf_builder.c(378) Module addressing
found in axis2.xml
[Mon Apr 20 13:02:37 2009] [error] ..\..\util\src\class_loader.c(167) Loading shared library
C:\wamp\bin\wsf_c/lib/axis2_http_sender.dll  Failed. DLERROR IS DLL Load Error 126: The specified
module could not be found.

[Mon Apr 20 13:02:37 2009] [error] ..\..\src\core\deployment\conf_builder.c(902) Transport
sender is NULL for transport http, unable to continue
[Mon Apr 20 13:02:37 2009] [error] ..\..\src\core\deployment\conf_builder.c(261) Processing
transport senders failed, unable to continue
[Mon Apr 20 13:02:37 2009] [error] ..\..\src\core\deployment\dep_engine.c(939) Populating
Axis2 Configuration failed
[Mon Apr 20 13:02:37 2009] [error] ..\..\src\core\deployment\conf_init.c(195) Loading deployment
engine failed for client repository C:\wamp\bin\wsf_c

Ben Dewey


Mime
View raw message