incubator-stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Sebor <se...@roguewave.com>
Subject Re: problem with Apache standard library
Date Tue, 24 Jun 2008 13:05:00 GMT
pendiala jaipal wrote:
> Hi all,
> 
> I built Apache Standard Library (stdcxx-4.2.1) on HPUX with acc 3.80 on 11.23PA platform.
> when i create binary using libstd.sl it is giving errors.
> 
> I followed these steps:
> 
> aCC /home/jaipal/stdcxx-4.2.1/build/include -mt -c -o t.o ex.cpp
> 
> aCC /home/jaipal/stdcxx-4.2.1/build/lib -mt t.o  ./libstd.sl  -o prog

You're missing some options on your command line. The most
important one is probably -AA (unless 3.80 changed the
default from -Ap to -AA). You can see the command line
options we use when building our tests and examples with
stdcxx in our nightly build logs, for example in this
LP64 build:

http://stdcxx.apache.org/builds/4.2.x/logs/hpux-11.23-pa-acc-3.73-12D-670084-log.gz.txt

   compile:  -AA -mt +O2 +DD64 +w +W392,655,684,818,819,849
   link:     -AA -mt +nostl +DD64 -Wl,+s

An easy way to check that things work as they should is
to compile, link, and run one of the example programs
provided with the library:

   $ cd $BUILDDIR/examples && gmake accumulate && ./accumulate

where BUILDDIR is the root of the directory where you chose
to build stdcxx ($TOPDIR/build by default, with TOPDIR being
the root of the stdcxx source tree where you expanded the
tarball).

Martin

> 
> it is giving error as  : /usr/ccs/bin/ld: /home/jaipal/Stdcxx/stdcxx-4.2.1.good/build/lib:
Not a valid object file (invalid system id)
> 
> if i run  aCC  mt t.o  ./libstd.sl  -o prog
> the prog binary is creating.
> 
> when i run the binary it is giving error as :
> 
> aCC runtime: Error 215 from shl_findsym ( home/jaipal/stdcxx-4.2.1/build/lib/libstd.sl
,_shlInit)' signal 11
> 
> 
> Can you please help me on this issue and also can you tell me how to test this apache
standard library .
> 
> Thanks in Advance,
> Jaipal Reddy P.


Mime
View raw message