incubator-stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Sebor <>
Subject Re: Issues with the build result pages
Date Thu, 05 Jun 2008 22:52:45 GMT
Travis Vitek wrote:
> There appears to be some kind of error with the x-platform build result
> pages for 4.3.x and trunk. On 4.2.x the page has only the latest build
> results as I'd expect. The 4.3.x and trunk pages look like the new
> results are being placed at the bottom. If you look at the actual html,
> you'll see that the page actually contains multiple <html></html>
> blocks, so I'm guessing that something that is supposed to delete or
> overwrite the file is just appending. 

Looks like the fix for this hasn't been merged yet:

> Another issue is the windows build results on 4.2.x. Many of the columns
> appear to contain data from the execution times instead of a string
> representing the exit code of the process or the failed assertions.
> [4.2.x]
> [4.3.x]
> [trunk]

I saw it this morning but haven't had time to investigate what's
causing it. I'm traveling the next two weeks and I'm not sure I'll
get around to it until I get back. It's most likely a problem in
the xcomp.awk script if you want to look into it. The way to test
it is to download a few logs and running xbuildgen on them like

(mkdir -p builds/logs && cd builds/logs && wget

&& PATH=~/stdcxx-4.2.x/bin:$PATH ~/stdcxx-4.2.x/bin/xbuildgen -s 
-o../test.html *-log.gz.txt)

This assumes you have a local copy of 4.2.x in stdcxx-4.2.x.


View raw message