incubator-stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Travis Vitek" <tvi...@quovadx.com>
Subject RE: [PATCH] Update test 22.locale.num.put.mt.cpp to validate results [take 2]
Date Tue, 14 Aug 2007 02:26:05 GMT
 
Martin Sebor wrote:
>
>>  
>> +#define countof(x) (sizeof (x) / sizeof (*x))
>
>Since you seem to like it so much ;-) we might as well move this
>macro to some central test suite header (and rename it according
>to the naming convention).
>

I'd love to, provided that we can define the naming convention to be
used for macros in the test suite. The style guide I've seen has
guidelines for names in the stdcxx implementation. I wouldn't think that
we would want the same convention used for macros defined in the
implementation as for macros defined within the test harness.

The only macros that appear to be named consistently are the header
guards. The names of other macros are pretty inconsistent. I'm guessing
that you want it to be underscore seperated uppercase, which is fine by
me. Some of the macros match this convention, of course many of them
don't. Some start with RW, others with _RWSTD or _TEST, and quite a few
of them don't have a prefix at all.

How does adding _TEST_COUNT_OF(x) to the bottom of testdefs.h sound?

Travis


Mime
View raw message