incubator-stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Black <abl...@roguewave.com>
Subject Re: Windows build results in the pink
Date Thu, 16 Aug 2007 21:26:32 GMT
Greetings Martin, all.

After arguing with the nightly testing system to get it to keep usable
post-build archives around, I finally managed to track down the cause of
the failure on Solaris AMD64. The problem, perhaps not surprisingly, is
the awk implementation used.  (See
http://mail-archives.apache.org/mod_mbox/incubator-stdcxx-dev/200707.mbox/%3c46AD0F69.6090706@roguewave.com%3e
, which is continued as
http://mail-archives.apache.org/mod_mbox/incubator-stdcxx-dev/200708.mbox/%3c46B25BE0.5010607@roguewave.com%3e
 for reference)

> [ablack@sunspot source-buildspace]$ awk -f parse_runlog.awk runall.log | tail -7
> warnings=0
> tests.run=0
> tests.good=0
> examples.run=0
> examples.good=0
> locales.run=0
> locales.good=0
> [ablack@sunspot source-buildspace]$ /usr/xpg4/bin/awk -f parse_runlog.awk runall.log
| tail -7
> warnings=0
> tests.run=0
> tests.good=0
> examples.run=135
> examples.good=129
> locales.run=166
> locales.good=162
> [ablack@sunspot source-buildspace]$ nawk -f parse_runlog.awk runall.log | tail -7
> warnings=75
> tests.run=341
> tests.good=275
> examples.run=135
> examples.good=129
> locales.run=166
> locales.good=162

At this time we are using /usr/xpg4/bin/awk on both sparc and AMD64.
Any thoughts?

--Andrew Black

Andrew Black wrote:
> Greetings Martin, all.
> 
> I had time on Friday to investigate the problem with the windows parser
> script, and checked in a change which resolved the issue.  I have not
> looked into the issue with result parsing on solaris 10 for AMD64.
> 
> --Andrew Black
> 
> Andrew Black wrote:
>> Greetings Martin
>>
>> I am currently occupied with another high-priority project, and hope to
>> finish it in the next couple days.  I'll look into these problems once
>> the other project has been dealt with.
>>
>> --Andrew Black
>>
>> Martin Sebor wrote:
>>> A similar problem exists in Solaris 10/AMD64 build results. There,
>>> examples and locales look like they are being reported correctly
>>> but tests are not.
>>>
>>> Martim
>>>
>>> Martin Sebor wrote:
>>>> Our latest Windows results are still having problems. I suspect it's
>>>> the fallout of the exec changes last week and the parsing script not
>>>> having been (fully) updated to adjust. Andrew, this is rather urgent
>>>> for us. Can you please look into it and let us know when we can
>>>> expect a fix?
>>>>
>>>> Thanks
>>>> Martin
>>>>

Mime
View raw message