incubator-stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Sebor <>
Subject Re: infinite loop in exec
Date Wed, 23 May 2007 21:55:04 GMT
Andrew Black wrote:
> Probably wouldn't hurt to open a jira for this, as I'm currently running 
> a sweep of results for our other products, and this may take a little 
> time to look into.

Wow, looks like it's already done! (Thanks Mark!)

> Interestingly, 

> indicates that the trunk version of the 21.cwchar test produces the 
> following message when run under the exec utility:
>> NAME                      STATUS WARN ASSERTS FAILED PERCNT    
>> USER     SYS    REAL
>> 21.cwchar                      0    0     169     10    94%   0.000   
>> 0.000   0.020

Yeah, I've seen that too.

> However, if your working copy has changed as a result of work you've 
> been doing, this data is likely not relevant.

That's a good point. I have reproduced the same behavior with
a fresh sync to the head of trunk.


> --Andrew Black
> Martin Sebor wrote:
>> I'm running into an (almost?) infinite loop when running some
>> of our tests under the exec utility on Linux (in a 12D build
>> with gcc 3.4.6 on Red Hat Advanced Server 4, I haven't tried
>> other configurations). The initial output of strace for one
>> of the tests, 21.cwchar, is in the attached file. The test
>> by itself runs fine to completion and doesn't produce any
>> unusual output (no NULs).
>> Andrew, when you have a chance, can you take a look at it?
>> If that's not going to be soon let me know if I should open
>> an issue.
>> Martin

View raw message