incubator-stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Sebor <>
Subject Re: replacement
Date Tue, 25 Jul 2006 16:09:41 GMT
Martin Sebor wrote:
> Andrew Black wrote:
>> Revised patch attached.
>> One change that I made while working on the self-test logic was to 
>> split the output parsing logic into parse_output.cpp/h.  I suspect 
>> you'll have a better name for the file.  That was bundled into this 
>> patch as I didn't take the time to back those changes out.
> Okay, I made a number of changes and committed everything here:
> One important change was removing the non-portable "-q" option
> from the invocation of diff (it was causing problems on Solaris).

Another change I forgot to mention was removing the (mostly)
redundant const qualifiers from function arguments (e.g.,
const int). The cv-qualifiers in function declarations are
ignored (i.e., they are not part of the function's type).
That said, they are respected in the definition of function
so that might be something to think about. For now, though,
the convention has been not to use const on function arguments
so let's stick to it until it's changed.


View raw message