incubator-stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Sebor <se...@roguewave.com>
Subject Re: svn commit: r412249 - in /incubator/stdcxx/trunk/tests: include/21.strings.h src/21.strings.cpp
Date Wed, 14 Jun 2006 19:52:52 GMT
Anton Pevtsov wrote:
> Martin Sebor wrote:
> 
>>This seems to include the changes for reverse_iterator. Shouldn't
> 
> those be implemented separately (and in the driver instead)?
> 
> Yes. I committed changes for range overloads in cons test here:
> http://svn.apache.org/viewvc?rev=414235&view=rev
> 
> 
> The updated test and test driver which supports the reverse iterators
> are here:
> http://people.apache.org/~antonp/stdcxx06142006/

This looks great, thanks! Could you please just give the
reverse_results helper function internal linkage (i.e.,
declare is static) and rename it to _rw_reverse_results
according to the naming convention? With that go ahead
and commit.

Martin

Mime
View raw message