incubator-stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Sebor <>
Subject Re: test for lib.string.access
Date Wed, 10 May 2006 19:41:51 GMT
Anton Pevtsov wrote:
> Martin, this is the signature for 
> at (size_type) const and 
> operator [] (size_type) const.

Right. Plus the non-const overload of each.

> Ther is small problem with brackets: our engine set it automatically
> before and after the signature description.
> But this signature is an exception: it should contain "const" after the
> brackets.

I'm not sure I understand. Could you show what it looks like?

> I see possible variants "at (size_type const)" or "at ((size_type)
> const)" without interference into the code.
> I think there is no need to provide special processing for this
> signature in the code. 
> What do you think about it?

I find "(size_type const)" confusing. More important, it would
interfere with a feature that I've been thinking about implementing
in the driver: the disabling/enabling of function tests based on
their decorated names (e.g., "at(size_type) const") rather than
using the naming convention we have in place now. I.e., it would
be nice to be able to tell the test suite driver: get me the test
results for, say, "std::string::at(size_type)" without having to
know which test to invoke or the name of the option to use with
the test to enable it and to disable all the others. This is
just a dream at this point but I don't want to make it harder
for us to implement it (if we ever decide to do so) than it
necessarily needs to be.


View raw message