incubator-stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Sebor (JIRA)" <>
Subject [jira] Created: (STDCXX-43) names of atomic functions inconsitent
Date Tue, 27 Sep 2005 21:40:50 GMT
names of atomic functions inconsitent

         Key: STDCXX-43
     Project: STDCXX
        Type: Improvement
  Components: Build  
    Versions: 4.1.2    
 Environment: all
    Reporter: Martin Sebor
     Fix For: 4.1.3

The names of the implementation-specific atomic functions are inconsistent: some contain the
width of the type they operate on (such as __rw_atomic_add32()), others don't (e.g., __rw_atomic_add32()),
and others still follow a different naming convention altogether (e.g., __rw_atomic_incr32()).
This makes understanding and writing the generic overloads that use them (e.g., __rw_atomic_preincrement(),
etc.) difficult and leads to lots of duplicate code in rw/_mutex.h. This is a placeholder
issue to rename these functions using a consistent naming convention and to simplify rw/_mutex.h.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message