incubator-stanbol-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alessandro Adamou <>
Subject SLF4J bindings
Date Wed, 04 May 2011 13:50:08 GMT

I started to get SLF4J-related errors when running Kres unit tests these 
days. Stuff like

SLF4J: slf4j-api 1.6.x (or later) is incompatible with this binding.
SLF4J: Your binding is version 1.5.5 or earlier.
SLF4J: Upgrade your binding to version 1.6.x. or 2.0.x

Tests won't run at all. Some failures occur when testing via Eclipse, 
others with Maven.

A mvn dependency:tree on the Stanbol root says that most Stanbol 
components are using 1.6.1 where I'm sitting today, as their POMs don't 
seem to specify a version.

We had forced version 1.5.2 for Kres bundles, both with slf4j-api and 
its bindings. Could it be time to stop depending on it? And what binding 
is best to adopt between slf4j-simple and slf4j-log4j12 ?

I don't think we have to stick to a specific version or binding, so long 
as the API stays compatible.



M.Sc. Alessandro Adamou

Alma Mater Studiorum - Università di Bologna
Department of Computer Science
Mura Anteo Zamboni 7, Bologna - Italy

Semantic Technology Laboratory (STLab)
Institute for Cognitive Science and Technology (ISTC)
National Research Council (CNR)
Via Nomentana 56, 00161 Rome - Italy

"As for the charges against me, I am unconcerned. I am beyond their timid, lying morality,
and so I am beyond caring."
(Col. Walter E. Kurtz)

View raw message