incubator-sling-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fmesc...@apache.org
Subject svn commit: r1510567 - in /sling/trunk/bundles/jcr/jackrabbit-usermanager: pom.xml src/main/java/org/apache/sling/jackrabbit/usermanager/impl/resource/AuthorizableResource.java
Date Mon, 05 Aug 2013 15:28:18 GMT
Author: fmeschbe
Date: Mon Aug  5 15:28:17 2013
New Revision: 1510567

URL: http://svn.apache.org/r1510567
Log:
SLING-2944 Revert Sling API dependency to 2.2.0 again

Sling API 2.4.0 is not required and probably only has been
updated to make sure the import version range for the Resource
API is correct. Given SLING-2993 we should actually provide
proper annotation of implemented API for the bundle plugin
to properly devise the import version range.

For now removing the 'provide:=true' import tag solves this
issue, since we only implement the ResourceProvider interface
(intended to be @ConsumerType) and extend AbstractSlingResource
(which is safe to extend in @ConsumerType fashion).

Modified:
    sling/trunk/bundles/jcr/jackrabbit-usermanager/pom.xml
    sling/trunk/bundles/jcr/jackrabbit-usermanager/src/main/java/org/apache/sling/jackrabbit/usermanager/impl/resource/AuthorizableResource.java

Modified: sling/trunk/bundles/jcr/jackrabbit-usermanager/pom.xml
URL: http://svn.apache.org/viewvc/sling/trunk/bundles/jcr/jackrabbit-usermanager/pom.xml?rev=1510567&r1=1510566&r2=1510567&view=diff
==============================================================================
--- sling/trunk/bundles/jcr/jackrabbit-usermanager/pom.xml (original)
+++ sling/trunk/bundles/jcr/jackrabbit-usermanager/pom.xml Mon Aug  5 15:28:17 2013
@@ -74,10 +74,6 @@
                 <extensions>true</extensions>
                 <configuration>
                     <instructions>
-                        <Import-Package>
-                            org.apache.sling.api.resource;provide:=true,
-                            *
-                        </Import-Package>
                         <Export-Package>
                             org.apache.sling.jackrabbit.usermanager;version=2.2.1,
                         </Export-Package>
@@ -103,7 +99,7 @@
         <dependency>
             <groupId>org.apache.sling</groupId>
             <artifactId>org.apache.sling.api</artifactId>
-            <version>2.4.0</version>
+            <version>2.2.0</version>
             <scope>provided</scope>
         </dependency>
         <dependency>

Modified: sling/trunk/bundles/jcr/jackrabbit-usermanager/src/main/java/org/apache/sling/jackrabbit/usermanager/impl/resource/AuthorizableResource.java
URL: http://svn.apache.org/viewvc/sling/trunk/bundles/jcr/jackrabbit-usermanager/src/main/java/org/apache/sling/jackrabbit/usermanager/impl/resource/AuthorizableResource.java?rev=1510567&r1=1510566&r2=1510567&view=diff
==============================================================================
--- sling/trunk/bundles/jcr/jackrabbit-usermanager/src/main/java/org/apache/sling/jackrabbit/usermanager/impl/resource/AuthorizableResource.java
(original)
+++ sling/trunk/bundles/jcr/jackrabbit-usermanager/src/main/java/org/apache/sling/jackrabbit/usermanager/impl/resource/AuthorizableResource.java
Mon Aug  5 15:28:17 2013
@@ -39,7 +39,7 @@ import org.apache.sling.api.resource.Val
     @Adapter(condition="If the resource is an AuthorizableResource and represents a JCR User",
value = User.class),
     @Adapter(condition="If the resource is an AuthorizableResource and represents a JCR Group",
value = Group.class)
 })
-public class AuthorizableResource extends AbstractResource implements Resource {
+public class AuthorizableResource extends AbstractResource {
     private Authorizable authorizable = null;
 
     private ResourceResolver resourceResolver = null;



Mime
View raw message