incubator-sling-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From conflue...@apache.org
Subject [CONF] Apache Sling > Towards Sling 6
Date Fri, 20 Aug 2010 14:05:00 GMT
<html>
<head>
    <base href="https://cwiki.apache.org/confluence">
            <link rel="stylesheet" href="/confluence/s/1810/9/1/_/styles/combined.css?spaceKey=SLING&amp;forWysiwyg=true"
type="text/css">
    </head>
<body style="background: white;" bgcolor="white" class="email-body">
<div id="pageContent">
<div id="notificationFormat">
<div class="wiki-content">
<div class="email">
    <h2><a href="https://cwiki.apache.org/confluence/display/SLING/Towards+Sling+6">Towards
Sling 6</a></h2>
    <h4>Page <b>edited</b> by             <a href="https://cwiki.apache.org/confluence/display/~fmeschbe">Felix
Meschberger</a>
    </h4>
        <br/>
                         <h4>Changes (17)</h4>
                                 
    
<div id="page-diffs">
            <table class="diff" cellpadding="0" cellspacing="0">
            <tr><td class="diff-snipped" >...<br></td></tr>
            <tr><td class="diff-unchanged" >Taken from the current definition
of what&#39;s part of a full Sling build found in the [bundle list in the Launchpad Builder
project|http://svn.apache.org/repos/asf/sling/trunk/launchpad/builder/src/main/bundles/list.xml]
here is a list of bundles currently (Revision 980813) referenced in the list and whether an
upgrade to a more recent version is desired for Sling 6. <br> <br></td></tr>
            <tr><td class="diff-added-lines" style="background-color: #dfd;">{toc:minLevel=2}
<br> <br>h2. Sling SNAPSHOT versions <br> <br></td></tr>
            <tr><td class="diff-unchanged" >The following is a list of Sling Bundles,
which are currently referred to as SNAPSHOT and require a release for Sling 6: <br>
<br>|Artifact|Current Version|Remark| <br></td></tr>
            <tr><td class="diff-deleted-lines" style="color:#999;background-color:#fdd;text-decoration:line-through;">|org.apache.sling.adapter|2.0.4|
Trunk has a minor stability fix --&gt; Release/Update | <br></td></tr>
            <tr><td class="diff-added-lines" style="background-color: #dfd;">|org.apache.sling.adapter|2.0.5-SNAPSHOT|
[Issues|https://issues.apache.org/jira/browse/SLING/fixforversion/12314288] | <br></td></tr>
            <tr><td class="diff-unchanged" >|org.apache.sling.api|2.0.9-SNAPSHOT|
[Issues|https://issues.apache.org/jira/browse/SLING/fixforversion/12314252] | <br>|org.apache.sling.auth.core|0.9.0-SNAPSHOT|
[Issues|https://issues.apache.org/jira/browse/SLING/fixforversion/12314514] | <br></td></tr>
            <tr><td class="diff-snipped" >...<br></td></tr>
            <tr><td class="diff-unchanged" >|org.apache.sling.bundleresource.impl|2.0.4-incubator|
Release for new Resource API; [Issues|https://issues.apache.org/jira/browse/SLING/fixforversion/12315239]
| <br>|org.apache.sling.commons.classloader|1.1.5-SNAPSHOT| [Issues|https://issues.apache.org/jira/browse/SLING/fixforversion/12314757]
| <br></td></tr>
            <tr><td class="diff-deleted-lines" style="color:#999;background-color:#fdd;text-decoration:line-through;">|org.apache.sling.commons.json|2.0.5-SNAPSHOT|
[Issues|https://issues.apache.org/jira/browse/SLING/fixforversion/12314500] - none of these
are user-visible, do we need to release? | <br></td></tr>
            <tr><td class="diff-added-lines" style="background-color: #dfd;">|org.apache.sling.commons.json|2.0.5-SNAPSHOT|
[Issues|https://issues.apache.org/jira/browse/SLING/fixforversion/12314500] | <br></td></tr>
            <tr><td class="diff-unchanged" >|org.apache.sling.commons.log|2.0.7-SNAPSHOT|
[Issues|https://issues.apache.org/jira/browse/SLING/fixforversion/12314139] | <br>|org.apache.sling.engine|2.0.7-SNAPSHOT|
[Issues|https://issues.apache.org/jira/browse/SLING/fixforversion/12314287] | <br>|org.apache.sling.extensions.groovy|1.0.0-SNAPSHOT|
[Issues|https://issues.apache.org/jira/browse/SLING/fixforversion/12315240] | <br></td></tr>
            <tr><td class="diff-changed-lines" ><span class="diff-changed-words">|org.apache.sling.extensions.webconsole<span
class="diff-added-chars"style="background-color: #dfd;">.</span>branding|0.0.1-SNAPSHOT|</span>
[Issues|https://issues.apache.org/jira/browse/SLING/fixforversion/12314456] | <br></td></tr>
            <tr><td class="diff-added-lines" style="background-color: #dfd;">|org.apache.sling.extensions.webconsole.securityprovider|0.0.1-SNAPSHOT|
Proposed for inclusion | <br></td></tr>
            <tr><td class="diff-unchanged" >|org.apache.sling.fsresource|1.0.1-SNAPSHOT|
[Issues|https://issues.apache.org/jira/browse/SLING/fixforversion/12314796] | <br>|org.apache.sling.jcr.api|2.0.7-SNAPSHOT|
[Issues|https://issues.apache.org/jira/browse/SLING/fixforversion/12314564] | <br></td></tr>
            <tr><td class="diff-snipped" >...<br></td></tr>
            <tr><td class="diff-unchanged" > <br> <br></td></tr>
            <tr><td class="diff-added-lines" style="background-color: #dfd;">h2.
Apache Sling Release Plan <br></td></tr>
            <tr><td class="diff-unchanged" > <br></td></tr>
            <tr><td class="diff-deleted-lines" style="color:#999;background-color:#fdd;text-decoration:line-through;">Artifacts
included in Sling 6 from outside the Sling project: <br></td></tr>
            <tr><td class="diff-added-lines" style="background-color: #dfd;">||
Batch || Artifact || Status || <br>| Sling API || org.apache.sling.api 2.1.0 | Vote
until 2010/08/21 | <br>| Authentication | org.apache.sling.auth.core 1.0.0\\ <br>org.apache.sling.auth.form
1.0.0\\ <br>org.apache.sling.auth.openid 1.0.0\\ <br>org.apache.sling.auth.selector
1.0.0 | RC build planned 2010/08/23 | <br>| Web Console Extensions | org.apache.sling.webconsole.branding
1.0.0 \\ <br>org.apache.sling.webconsole.securityprovider 1.0.0 | RC build planned 2010/08/23
| <br>| Engine | org.apache.sling.adapter 2.0.6 \\ <br>org.apache.sling.engine
2.1.0 | RC build planned week 2010/08/26 | <br>| Classloader | org.apache.sling.commons.classloader
1.2.0 \\ <br>org.apache.sling.jcr.classloader 3.1.1-SNAPSHOT| [Issues|https://issues.apache.org/jira/browse/SLING/fixforversion/12314758]
| <br>| JCR Bundles | org.apache.sling.jcr.api 2.1.0 \\ <br>org.apache.sling.jcr.base
2.1.0 \\ <br>org.apache.sling.jcr.contentloader 2.0.8 \\ <br>org.apache.sling.jcr.davex
1.0.0 \\ <br>org.apache.sling.jcr.jackrabbit.accessmanager 2.0.6 \\ <br>org.apache.sling.jcr.jackrabbit.server
2.0.8 \\ <br>org.apache.sling.jcr.jackrabbit.usermanager 2.0.6 \\ <br>org.apache.sling.jcr.webconsole
1.0.0 \\ <br>org.apache.sling.jcr.webdav 2.0.10 | TBD | <br>| Scripting | org.apache.sling.scripting.core
2.0.12 \\ <br>org.apache.sling.scripting.javascript 2.0.8 \\ <br>org.apache.sling.scripting.jsp
2.0.10 \\ <br>org.apache.sling.scripting.jsp.taglib 2.1.0 | TBD | <br>| Servlets
| org.apache.sling.servlets.get 2.0.10 \\ <br>org.apache.sling.servlets.post 2.0.6 \\
<br>org.apache.sling.servlets.resolver 2.0.10 | TBD | <br>| Launchpad Base | org.apache.sling.launchpad.base
2.2.2 \\ <br>org.apache.sling.launchpad.content 2.0.6 | After Felix Framework 3.0.2
release | <br>| Resource | org.apache.sling.bundleresource.impl 2.0.6 \\ <br>org.apache.sling.fsresource
1.0.2 \\ <br>org.apache.sling.jcr.resource 2.0.8 | TBD | <br>| Misc | |org.apache.sling.commons.json
2.0.6 \\ <br>org.apache.sling.commons.log 2.0.8 \\ <br>org.apache.sling.extensions.groovy
1.0.0 | TBD | <br></td></tr>
            <tr><td class="diff-unchanged" > <br></td></tr>
            <tr><td class="diff-added-lines" style="background-color: #dfd;">
<br> <br> <br>h2. Artifacts included in Sling 6 from outside the Sling project
<br> <br></td></tr>
            <tr><td class="diff-unchanged" >|Artifact|Current Version|Remark|
<br>|commons-fileupload|1.2.2| See note 1 | <br></td></tr>
            <tr><td class="diff-snipped" >...<br></td></tr>
            <tr><td class="diff-unchanged" >|derby|10.5.3.0_1| Upgrade to Derby
10.6.1.0 ? See [release notes|http://old.nabble.com/-ANNOUNCE--Apache-Derby-10.6.1.0-released-td28610453.html]
| <br>|groovy-all|1.7.4| See note 1 | <br></td></tr>
            <tr><td class="diff-deleted-lines" style="color:#999;background-color:#fdd;text-decoration:line-through;">|tika-bundle|0.6|
Upgrade to Tika 0.6 ? See [release notes|http://tika.apache.org/0.7/index.html] | <br></td></tr>
            <tr><td class="diff-added-lines" style="background-color: #dfd;">|org.apache.felix.bundlerepository|1.6.4
| See note 1 | <br>|org.apache.felix.eventadmin|1.2.2| See note 1 | <br>|org.apache.felix.framework|3.1.0-SNAPSHOT
| Included in the Launchpad Base Module. See note 1. Felix Framework 3.0.2 release is being
voted on. | <br></td></tr>
            <tr><td class="diff-unchanged" >|org.apache.felix.http.whiteboard|2.0.4|
Related to Apache Felix HTTP support contained in the Launchpad Base module. There have been
a few updates to Apache Felix HTTP trunk. Should we update ? | <br></td></tr>
            <tr><td class="diff-added-lines" style="background-color: #dfd;">|org.apache.felix.scr|1.6.0|
See note 1 | <br></td></tr>
            <tr><td class="diff-unchanged" >|org.apache.felix.webconsole|3.1.2
| See note 1 | <br>|org.apache.felix.webconsole.plugins.event|1.0.2| | <br>|org.apache.felix.webconsole.plugins.memoryusage|1.0.2|
See note 1 | <br></td></tr>
            <tr><td class="diff-deleted-lines" style="color:#999;background-color:#fdd;text-decoration:line-through;">|org.apache.felix.bundlerepository|1.6.4
| See note 1 | <br>|org.apache.felix.eventadmin|1.2.2| See note 1 | <br>|org.apache.felix.scr|1.6.0|
See note 1 | <br></td></tr>
            <tr><td class="diff-added-lines" style="background-color: #dfd;">|tika-bundle|0.6|
Upgrade to Tika 0.6 ? See [release notes|http://tika.apache.org/0.7/index.html] | <br></td></tr>
            <tr><td class="diff-unchanged" > <br>Note 1: As of [SLING-1623|https://issues.apache.org/jira/browse/SLING-1623]
these dependencies have been updated to the most recent release (or SNAPSHOT where a release
must be cut before Sling 6) <br> <br></td></tr>
            <tr><td class="diff-added-lines" style="background-color: #dfd;">
<br>h2. Dependencies not needing update <br> <br></td></tr>
            <tr><td class="diff-unchanged" >The following dependencies listed
in {{list.xml}} are current versions or have been decided to not require and update and are
ready for use in Sling 6: <br> <br></td></tr>
            <tr><td class="diff-snipped" >...<br></td></tr>
        </table>
</div>                            <h4>Full Content</h4>
                    <div class="notificationGreySide">
        <p>A full Sling release is long overdue with the last full release Sling 5 dating
back to May 2009. A number of bundles have been released independently in the mean time and
much work has again been done around the core Sling API.</p>

<p>Taken from the current definition of what's part of a full Sling build found in the
<a href="http://svn.apache.org/repos/asf/sling/trunk/launchpad/builder/src/main/bundles/list.xml"
class="external-link" rel="nofollow">bundle list in the Launchpad Builder project</a>
here is a list of bundles currently (Revision 980813) referenced in the list and whether an
upgrade to a more recent version is desired for Sling 6.</p>

<div>
<ul>
    <li><a href='#TowardsSling6-SlingSNAPSHOTversions'>Sling SNAPSHOT versions</a></li>
    <li><a href='#TowardsSling6-ApacheSlingReleasePlan'>Apache Sling Release Plan</a></li>
    <li><a href='#TowardsSling6-ArtifactsincludedinSling6fromoutsidetheSlingproject'>Artifacts
included in Sling 6 from outside the Sling project</a></li>
    <li><a href='#TowardsSling6-Dependenciesnotneedingupdate'>Dependencies not
needing update</a></li>
</ul></div>

<h2><a name="TowardsSling6-SlingSNAPSHOTversions"></a>Sling SNAPSHOT versions</h2>

<p>The following is a list of Sling Bundles, which are currently referred to as SNAPSHOT
and require a release for Sling 6:</p>

<div class='table-wrap'>
<table class='confluenceTable'><tbody>
<tr>
<td class='confluenceTd'>Artifact</td>
<td class='confluenceTd'>Current Version</td>
<td class='confluenceTd'>Remark</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.adapter</td>
<td class='confluenceTd'>2.0.5-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314288"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.api</td>
<td class='confluenceTd'>2.0.9-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314252"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.auth.core</td>
<td class='confluenceTd'>0.9.0-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314514"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.auth.form</td>
<td class='confluenceTd'>0.9-SNAPSHOT</td>
<td class='confluenceTd'> Add new bundle; <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314785"
class="external-link" rel="nofollow">Issues</a>  </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.auth.openid</td>
<td class='confluenceTd'>0.9.1-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314515"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.bundleresource.impl</td>
<td class='confluenceTd'>2.0.4-incubator</td>
<td class='confluenceTd'> Release for new Resource API; <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12315239"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.commons.classloader</td>
<td class='confluenceTd'>1.1.5-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314757"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.commons.json</td>
<td class='confluenceTd'>2.0.5-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314500"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.commons.log</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314139"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.engine</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314287"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.extensions.groovy</td>
<td class='confluenceTd'>1.0.0-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12315240"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.extensions.webconsole.branding</td>
<td class='confluenceTd'>0.0.1-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314456"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.extensions.webconsole.securityprovider</td>
<td class='confluenceTd'>0.0.1-SNAPSHOT</td>
<td class='confluenceTd'> Proposed for inclusion </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.fsresource</td>
<td class='confluenceTd'>1.0.1-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314796"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.api</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314564"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.base</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314768"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.classloader</td>
<td class='confluenceTd'>3.1.1-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314758"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.contentloader</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314472"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.davex</td>
<td class='confluenceTd'>0.9.0-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12315241"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.jackrabbit.accessmanager</td>
<td class='confluenceTd'>2.0.5-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314774"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.jackrabbit.server</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314769"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.jackrabbit.usermanager</td>
<td class='confluenceTd'>2.0.5-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314773"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.resource</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314286"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.webconsole</td>
<td class='confluenceTd'>1.0.0-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314502"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.webdav</td>
<td class='confluenceTd'>2.0.9-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314772"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.launchpad.base</td>
<td class='confluenceTd'>2.2.1-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314956"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.launchpad.content</td>
<td class='confluenceTd'>2.0.5-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12315242"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.scripting.core</td>
<td class='confluenceTd'>2.0.11-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314797"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.scripting.javascript</td>
<td class='confluenceTd'>2.0.6</td>
<td class='confluenceTd'> Trunk has a fix in preserving scope --&gt; Release/Update;
<a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314406" class="external-link"
rel="nofollow">Issues</a>  </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.scripting.jsp</td>
<td class='confluenceTd'>2.0.9-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314407"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.scripting.jsp.taglib</td>
<td class='confluenceTd'>2.0.7-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314408"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.servlets.get</td>
<td class='confluenceTd'>2.0.9-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314473"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.servlets.post</td>
<td class='confluenceTd'>2.0.5-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314180"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.servlets.resolver</td>
<td class='confluenceTd'>2.0.9-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314292"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
</tbody></table>
</div>



<h2><a name="TowardsSling6-ApacheSlingReleasePlan"></a>Apache Sling Release
Plan</h2>

<div class='table-wrap'>
<table class='confluenceTable'><tbody>
<tr>
<th class='confluenceTh'> Batch </th>
<th class='confluenceTh'> Artifact </th>
<th class='confluenceTh'> Status </th>
</tr>
<tr>
<td class='confluenceTd'> Sling API </td>
<th class='confluenceTh'> org.apache.sling.api 2.1.0 </th>
<td class='confluenceTd'> Vote until 2010/08/21 </td>
</tr>
<tr>
<td class='confluenceTd'> Authentication </td>
<td class='confluenceTd'> org.apache.sling.auth.core 1.0.0<br class="atl-forced-newline"
/>
org.apache.sling.auth.form 1.0.0<br class="atl-forced-newline" />
org.apache.sling.auth.openid 1.0.0<br class="atl-forced-newline" />
org.apache.sling.auth.selector 1.0.0 </td>
<td class='confluenceTd'> RC build planned 2010/08/23 </td>
</tr>
<tr>
<td class='confluenceTd'> Web Console Extensions </td>
<td class='confluenceTd'> org.apache.sling.webconsole.branding 1.0.0 <br class="atl-forced-newline"
/>
org.apache.sling.webconsole.securityprovider 1.0.0 </td>
<td class='confluenceTd'> RC build planned 2010/08/23 </td>
</tr>
<tr>
<td class='confluenceTd'> Engine </td>
<td class='confluenceTd'> org.apache.sling.adapter 2.0.6 <br class="atl-forced-newline"
/>
org.apache.sling.engine 2.1.0 </td>
<td class='confluenceTd'> RC build planned week 2010/08/26 </td>
</tr>
<tr>
<td class='confluenceTd'> Classloader </td>
<td class='confluenceTd'> org.apache.sling.commons.classloader 1.2.0 <br class="atl-forced-newline"
/>
org.apache.sling.jcr.classloader 3.1.1-SNAPSHOT</td>
<td class='confluenceTd'> <a href="https://issues.apache.org/jira/browse/SLING/fixforversion/12314758"
class="external-link" rel="nofollow">Issues</a> </td>
</tr>
<tr>
<td class='confluenceTd'> JCR Bundles </td>
<td class='confluenceTd'> org.apache.sling.jcr.api 2.1.0 <br class="atl-forced-newline"
/>
org.apache.sling.jcr.base 2.1.0 <br class="atl-forced-newline" />
org.apache.sling.jcr.contentloader 2.0.8 <br class="atl-forced-newline" />
org.apache.sling.jcr.davex 1.0.0 <br class="atl-forced-newline" />
org.apache.sling.jcr.jackrabbit.accessmanager 2.0.6 <br class="atl-forced-newline" />
org.apache.sling.jcr.jackrabbit.server 2.0.8 <br class="atl-forced-newline" />
org.apache.sling.jcr.jackrabbit.usermanager 2.0.6 <br class="atl-forced-newline" />
org.apache.sling.jcr.webconsole 1.0.0 <br class="atl-forced-newline" />
org.apache.sling.jcr.webdav 2.0.10 </td>
<td class='confluenceTd'> TBD </td>
</tr>
<tr>
<td class='confluenceTd'> Scripting </td>
<td class='confluenceTd'> org.apache.sling.scripting.core 2.0.12 <br class="atl-forced-newline"
/>
org.apache.sling.scripting.javascript 2.0.8 <br class="atl-forced-newline" />
org.apache.sling.scripting.jsp 2.0.10 <br class="atl-forced-newline" />
org.apache.sling.scripting.jsp.taglib 2.1.0 </td>
<td class='confluenceTd'> TBD </td>
</tr>
<tr>
<td class='confluenceTd'> Servlets </td>
<td class='confluenceTd'> org.apache.sling.servlets.get 2.0.10 <br class="atl-forced-newline"
/>
org.apache.sling.servlets.post 2.0.6 <br class="atl-forced-newline" />
org.apache.sling.servlets.resolver 2.0.10 </td>
<td class='confluenceTd'> TBD </td>
</tr>
<tr>
<td class='confluenceTd'> Launchpad Base </td>
<td class='confluenceTd'> org.apache.sling.launchpad.base 2.2.2 <br class="atl-forced-newline"
/>
org.apache.sling.launchpad.content 2.0.6 </td>
<td class='confluenceTd'> After Felix Framework 3.0.2 release </td>
</tr>
<tr>
<td class='confluenceTd'> Resource </td>
<td class='confluenceTd'> org.apache.sling.bundleresource.impl 2.0.6 <br class="atl-forced-newline"
/>
org.apache.sling.fsresource 1.0.2 <br class="atl-forced-newline" />
org.apache.sling.jcr.resource 2.0.8 </td>
<td class='confluenceTd'> TBD </td>
</tr>
<tr>
<td class='confluenceTd'> Misc </td>
<td class='confluenceTd'>&nbsp;</td>
<td class='confluenceTd'>org.apache.sling.commons.json 2.0.6 <br class="atl-forced-newline"
/>
org.apache.sling.commons.log 2.0.8 <br class="atl-forced-newline" />
org.apache.sling.extensions.groovy 1.0.0 </td>
<td class='confluenceTd'> TBD </td>
</tr>
</tbody></table>
</div>





<h2><a name="TowardsSling6-ArtifactsincludedinSling6fromoutsidetheSlingproject"></a>Artifacts
included in Sling 6 from outside the Sling project</h2>

<div class='table-wrap'>
<table class='confluenceTable'><tbody>
<tr>
<td class='confluenceTd'>Artifact</td>
<td class='confluenceTd'>Current Version</td>
<td class='confluenceTd'>Remark</td>
</tr>
<tr>
<td class='confluenceTd'>commons-fileupload</td>
<td class='confluenceTd'>1.2.2</td>
<td class='confluenceTd'> See note 1 </td>
</tr>
<tr>
<td class='confluenceTd'>commons-lang</td>
<td class='confluenceTd'>2.5</td>
<td class='confluenceTd'> See note 1 </td>
</tr>
<tr>
<td class='confluenceTd'>derby</td>
<td class='confluenceTd'>10.5.3.0_1</td>
<td class='confluenceTd'> Upgrade to Derby 10.6.1.0 ? See <a href="http://old.nabble.com/-ANNOUNCE--Apache-Derby-10.6.1.0-released-td28610453.html"
class="external-link" rel="nofollow">release notes</a> </td>
</tr>
<tr>
<td class='confluenceTd'>groovy-all</td>
<td class='confluenceTd'>1.7.4</td>
<td class='confluenceTd'> See note 1 </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.bundlerepository</td>
<td class='confluenceTd'>1.6.4 </td>
<td class='confluenceTd'> See note 1 </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.eventadmin</td>
<td class='confluenceTd'>1.2.2</td>
<td class='confluenceTd'> See note 1 </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.framework</td>
<td class='confluenceTd'>3.1.0-SNAPSHOT </td>
<td class='confluenceTd'> Included in the Launchpad Base Module. See note 1. Felix Framework
3.0.2 release is being voted on. </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.http.whiteboard</td>
<td class='confluenceTd'>2.0.4</td>
<td class='confluenceTd'> Related to Apache Felix HTTP support contained in the Launchpad
Base module. There have been a few updates to Apache Felix HTTP trunk. Should we update ?
</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.scr</td>
<td class='confluenceTd'>1.6.0</td>
<td class='confluenceTd'> See note 1 </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.webconsole</td>
<td class='confluenceTd'>3.1.2 </td>
<td class='confluenceTd'> See note 1 </td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.webconsole.plugins.event</td>
<td class='confluenceTd'>1.0.2</td>
<td class='confluenceTd'>&nbsp;</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.webconsole.plugins.memoryusage</td>
<td class='confluenceTd'>1.0.2</td>
<td class='confluenceTd'> See note 1 </td>
</tr>
<tr>
<td class='confluenceTd'>tika-bundle</td>
<td class='confluenceTd'>0.6</td>
<td class='confluenceTd'> Upgrade to Tika 0.6 ? See <a href="http://tika.apache.org/0.7/index.html"
class="external-link" rel="nofollow">release notes</a> </td>
</tr>
</tbody></table>
</div>


<p>Note 1: As of <a href="https://issues.apache.org/jira/browse/SLING-1623" class="external-link"
rel="nofollow">SLING-1623</a> these dependencies have been updated to the most recent
release (or SNAPSHOT where a release must be cut before Sling 6)</p>


<h2><a name="TowardsSling6-Dependenciesnotneedingupdate"></a>Dependencies
not needing update</h2>

<p>The following dependencies listed in <tt>list.xml</tt> are current versions
or have been decided to not require and update and are ready for use in Sling 6:</p>

<div class='table-wrap'>
<table class='confluenceTable'><tbody>
<tr>
<td class='confluenceTd'>Artifact</td>
<td class='confluenceTd'>Version</td>
</tr>
<tr>
<td class='confluenceTd'>commons-io</td>
<td class='confluenceTd'>1.4</td>
</tr>
<tr>
<td class='confluenceTd'>commons-collections</td>
<td class='confluenceTd'>3.2.1</td>
</tr>
<tr>
<td class='confluenceTd'>jackrabbit-api</td>
<td class='confluenceTd'>2.1.0</td>
</tr>
<tr>
<td class='confluenceTd'>jackrabbit-jcr-commons</td>
<td class='confluenceTd'>2.1.0</td>
</tr>
<tr>
<td class='confluenceTd'>jackrabbit-spi</td>
<td class='confluenceTd'>2.1.0</td>
</tr>
<tr>
<td class='confluenceTd'>jackrabbit-spi-commons</td>
<td class='confluenceTd'>2.1.0</td>
</tr>
<tr>
<td class='confluenceTd'>jackrabbit-jcr-rmi</td>
<td class='confluenceTd'>2.1.0</td>
</tr>
<tr>
<td class='confluenceTd'>jcr</td>
<td class='confluenceTd'>2.0</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.aries.jmx.api</td>
<td class='confluenceTd'>0.1-incubating</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.aries.jmx.core</td>
<td class='confluenceTd'>0.1-incubating</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.configadmin</td>
<td class='confluenceTd'>1.2.4</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.felix.metatype</td>
<td class='confluenceTd'>1.0.4</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.commons.mime</td>
<td class='confluenceTd'>2.1.4</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.commons.osgi</td>
<td class='confluenceTd'>2.0.6</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.extensions.threaddump</td>
<td class='confluenceTd'>0.2.0</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.jcr.ocm</td>
<td class='confluenceTd'>2.0.4-incubator</td>
</tr>
<tr>
<td class='confluenceTd'>org.apache.sling.scripting.api</td>
<td class='confluenceTd'>2.1.0</td>
</tr>
</tbody></table>
</div>

    </div>
        <div id="commentsSection" class="wiki-content pageSection">
        <div style="float: right;">
            <a href="https://cwiki.apache.org/confluence/users/viewnotifications.action"
class="grey">Change Notification Preferences</a>
        </div>
        <a href="https://cwiki.apache.org/confluence/display/SLING/Towards+Sling+6">View
Online</a>
        |
        <a href="https://cwiki.apache.org/confluence/pages/diffpagesbyversion.action?pageId=23333743&revisedVersion=17&originalVersion=16">View
Changes</a>
                |
        <a href="https://cwiki.apache.org/confluence/display/SLING/Towards+Sling+6?showComments=true&amp;showCommentArea=true#addcomment">Add
Comment</a>
            </div>
</div>
</div>
</div>
</div>
</body>
</html>

Mime
View raw message